Solder mask broken by track


I have a strange situation where the solder mask is broken by the track. The result is a strange PCB where the exposed pads have these little extrusions instead of being nicely rectangular or circular shaped.
I never had this problem before. (I just started using KiCad 5.) I probably have some setting wrong. The solder mask and pad clearances are all zero.
What is causing this?

I can not see anything strange in your screenshot. Could you mark the problematic area? (plus maybe include some drawing of how you expect it to look like?)

Also maybe look at the pcb using the 3d viewer in realistic rendering mode. Maybe you have the wrong idea of how some things will look like in the final product.


Here’s the output from one of the gerber viewers. You see what I mean?
I also added red circles in the first image.

I see free copper where a trace enters a pad. This is exactly what one would expect.

You have however a very large mask clearance setting. You might want to change that in the settings of the board. (in kicad version 5 this is found in the setup menu and in v4 in the dimension menu. In current nightly it is found under the file menu.)
Check your manufacturers capabilities on how this should be setup. (It is not suggested to use their lowest limit unless you really need this setting.)

This is an effect of the large default soldermask clearance in Kicad. You could mark as affecting you.

Thanks! That makes sense. I think I looked in the “Local Clearance and Settings” tab under the Setup->“Default Pad Properties”. However, Setup->“Pads to Mask Clearance” is the place to go to change the default. (KiCad 5).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.