Small Failure ? Editing single Pads

Hello ! I love the possibility to edit a single pad that s already part of a footprint without editing the footprint itself.
When I changed from 4.x to 5.0 this function seemed to have vanished. Only in legacy graphics mode the Pads could be selected for editing.
But then I found out: You have to activate the Top-Layer to select the Pads ! It does not matter if you are actually using this layer and that the Pads are defined on all layers.

I am in open gl mode, kicad 5 under ubuntu.

I can select pads no matter what layer has the blue triangle next to it. (I assume this is what you mean with active layer) I can also directly use the shortcut e on them regardless of active layer.

Is it possible you are in high contrast mode?

No, I know the high contrast mode but this independent. Maybe it is related to my OGL ? Im using Mint with the nuveau driver. It is not a noGo, just strange. When i turn off the top layer I will always access the footprint properties. Kicad dont even ask if I wanted the single pad.

try different places in the area of the pad. avoid areas where there is anything on another layer.

Has your footprint a closed polygon on courtyard? Maybe kicad bugs out with open courtyard drawings. (Do you get the same result with official kicad footprints?)

OK you give me some work to do :wink:
Ill will try this and come back tomorrow ! As a matter of fact my layout contains “old” footprints…

By the way: Greetings to You, You are fast ! and I would like to greet ALL people working “for” kicad. This is wonderful SW and V5 can compete with others easily !

Hi, back again.
I tried different places to click and I tried old and new (Kicad5) footprints.

It is always the same: When the top Layer is off, Kicad does not recognize single Pads. And it does not ask which element I am looking for, always choosing either track or footprint . The strange thing is: this even happens when I try to edit SMD-Pads on the bottom Layer.
When the top layer is switched on, the footprint is only recognized when I click its anchor point. Pad and Track are found accordingly - sometimes with a questioning dialog.

Oh now i understand. With active you meant the tickmark next to it. The one that controls visibility. That is definitely a bug in the opengl mode.

I submitted a bug report for this:

Aah, the visibility switch is called “tickmark”. I didn t know that. :bulb:

I tried the OGL fallback mode - but the behavior is the same.

Anyway, its no problem for me to keep the top layer switched on. So I can wait for future updates.

Thank you very much for your help !

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.