Small black dots in Gerber Viewer

I have a pretty strange issue with the gerber viewer. At the default zoom level, there are these small black dots that appear all over my layers. I only see it with the copper layers, and only where the copper isn’t being drilled.

At most zoom levels they aren’t there, but zooming in two mouse wheel scrolls from the default brings them back, as does zooming three or four mouse wheel scrolls out from the default. The spacing is different at the different zoom levels.

Is this a bug? If not, how can I get rid of them?

Let me guess - this is created with very old KiCad version? (You should always give exact version information from Help menu.)

Could it be the grid? right sidebar: items -> grid check if the colour selected for it is something dark.

1 Like

My mistake, here’s the version info:
Application: GerbView
Version: 5.1.4-e60b266~84~ubuntu18.04.1, release build
wxWidgets 3.0.4
libcurl/7.58.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 5.0.0-32-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
Boost: 1.65.1
OpenCASCADE Community Edition: 6.9.1
Curl: 7.58.0
Compiler: GCC 7.4.0 with C++ ABI 1011

Build settings:

I have the grid off in items, so it’s not that. It seems like some sort of rendering glitch to me. See the horizontal line of this screenshot where some of the dots are missing? If I zoom in on that area and zoom back out, the line of dots is completely there, and there’s another area that’s missing some dots.image

But the file name reveals that the gerber file isn’t generated with 5.1.4.

Use the left hand toolbar buttons and select outline modes for everything. Then show us what you see. Or give the gerber file here.

I regenerated the gerber files with the same KiCAD version.

It looks like KiCad has filled the zone with traces. This shouldn’t be so, and I don’t know why it happens. There only reason I can imagine is this (speculating):

Going back in history, KiCad filled zones this way. The board is made with an old KiCad version and zones have a setting which controls filling. That setting is hidden in new KiCad and can’t be set/unset, but KiCad still uses it.

Can you share the project (or at least the board file)?

If @eelik is right, it can be solved editing the .kicad_pcb file

Close Kicad and pcbnew.
Open the .kicad_pcb file with a text editor and search for arc_segments. If you find arc_segments 16, change it to arc_segments 32. Save the file.

Now reopen kicad, pcbnew and retry.
Let us know how it worked.

Maybe it’s better to use KiCad. When I try to accept zone properties in KiCad 5.1.4 after opening an old file with segment filling, I get this:

And BTW, changing arc_segements doesn’t help. It’s removing “(mode segment)” which does it.

1 Like

I installed 4.0.7 to test this, and yes, it can create segment filled zones. “mode segment” is then understood and used by KiCad 5.1.4 unless zones are edited.

The small dots (or lines) in rendering are a small bug. The same happens sometimes with pcbnew, too, when two items touch each other side by side. It shouldn’t affect functionality, though.

Segment fill is deprecated officially in Gerber documents. It’s better to use polygon fill (which is the default, implicit and only option in KiCad 5).

1 Like

electroplating_controller.kicad_pcb (749.0 KB)

Here’s the unmodified .kicad_pcb file. I removed the “(mode segment)” in the two locations it appeared in the file, generated the Gerbers from the modified file, and that solved it. Thanks a lot for the help!

Actually, it seems like the upload isn’t working, so I pasted it into this pastebin alternative.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.