Slowing down the panning speed while moving a footprint in PCBNew?


#1

Is there a way to slow down the panning speed while moving a footprint in PCBNew? What I mean is when you are moving a footprint, and you get to the edge of the window, the background starts panning, but the panning happens super fast, and all of a sudden you are in the middle of nowhere, and have to zoom out and then zoom back into the area of interest. It would be ideal if the panning happened at a rate that my slow senses/reaction time could follow.


#2

I wonder if this is program specific or tied to your OS settings. I’ve never had the problem though. I use Linux. Even when forced to use windoze as a contractor I’d set my mouse speed and acceleration all the way up. It drove people trying to use my computer nuts but my hand doesn’t move from one spot on the desk. I just pivot the wrist and fingers a bit. :wink:


#3

If you compile from source this is an easy fix in the WX_VIEW_CONTROLS::handleAutoPanning function in wx_view_controls.cpp and is one of the things I do with every new compile.

Whether this affects anything else I don’t know. I approach coding like a lumberjack approaches a tree, hack, hack, hack until a problem falls over, but it doesn’t always fall the right way.


#4

Interesting. Maybe someday I’ll look into compiling kicad. Thanks.