"Show module ratsnest" function disappeared


#1

Hi,
I just upgraded to v.5.1.0 (coming, I believe, from 5.0.1) and noticed, with utter disappointment, that the “Show module ratsnest” function is no longer available!!!
This apparently leaves no way to show the ratnest for the module currently being moved.
That is only shown if the legacy toolset is used (which frankly appears very limiting, besides being deprecated for the near future)… why would anyone remove such a basic function??? Are there technical reasons for that? Should I file a bug for that or is it an (inconsiderate) design choice?

Application: pcbnew
Version: (6.0.0-rc1-dev-1681-g5edf3503c), release build
Libraries:
wxWidgets 3.0.4
libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.68.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.1
Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON


#2

You are running a nightly, not the 5.1.0 stable version.

That’s said, the “Display local ratsnest” works as expected under ubuntu and 5.1.0 with the modern toolset accelerated, third icon on the right toolbar.


#3

And one before 5.1 at that, not post-5.1.


#4

Sorry for the mismatch, my bad. The version number looked odd to me too so I checked - I had a wrong path in my registry, so that’s definitely a nightly that I had installed for testing (not a pre-5.1, since I just downloaded it and it appears to be a 6.0.0-rc1).
However, I re-tested it with the correct versions and my claim still stands as follows:

The version I was previously using was (5.0.2)-1; the function I mentioned (as far as buttons are concerned) was already gone in that version, but at least - and that why I hadn’t noticed at first - selecting and moving a component was still showing the ratsnest, as I was used to. Wouldn’t know how it can be disabled though.

When I updated to Version: (5.1.0)-1, this behaviour changed and ratnest when moving was no longer there (nor I have a clue on how to activate it). It does not look like removal was due to a technical reason, because it worked in the previous release.

The command you mentioned, “Display local ratsnest”, AFAIK is not the same as “Show module ratsnest”, which was originally on the left toolbar right below “Show board ratsnest”.
The “local” version is static (disappears as soon as anything else is selected), whereas the “module” version is the behaviour I’m talking about.


#5

I wonder what that is, because up to date nightlies report them as 5.1.0-something. Before 5.1 they were 6.0.0-rc1-something.


#6

I have checked with version 4.0.7.
You are right, the icon on the left toolbar for module ratsnest is not present in 5.1.0

But its functionality is present on the right toolbar Display local ratsnest:
If a pad is selected it works as the old Display local ratsnest (same as before)
If a footprint is selected it works as the old Show module ratsnest


#7

I have to partially disagree; there is a slight but significant difference.
In the previous version, moving the component made the ratsnest appear automatically (if the option was selected that way);
now, one must undergo an annoying sequence of operations (go to button / click, go to component / click, “m”, move, position, go to button / click, click elsewhere) in order to achieve the same result. And I can’t really find any rationale to it, all the more because it would just have involved leaving a button which was already there in the first place.


#8

You can report it as a bug in the bug database.


#9

Thanks, I probably will, I just wanted to check if anyone else was affected by this change or if there was a sound reason for it.


#10

I ran into the same problem, 5.1.0-0 on latest Mac.

The old functionality of automatically showing the local ratsnest when moving a component definitely suits me better, too. As you mentioned, it now requires an extra click (or hotkey?) to activate it first, then select the component.

At least I now know how to turn this on at all, I thought I remembered it being a preference setting and couldn’t find that anywhere. Google was my friend, again. For a short while I went with Option B, which was selecting the legacy toolset during the times I’m placing components, then switching back for the actual layout phase.

So yes, +1 for filing a bug report or feature request if it’s possible to get it back.

Thanks again to Rene, Pedro and all the other regular elfs here that help answering such questions!