Shared Library Management Using SharePoint

I am using KiCad in a corporate environment with a handful of engineers all utilising KiCad for schematic and layout design. Currently we all have individual libraries setup locally but i want to drive to using SharePoint as cloud based shared library.

This seems to be working great for symbols & footprints by each individual setting up the lib table for symbols & footprints to point to their local file path (which is in the format C:/Users/username/SharePoint address/library) for the SharePoint location as a one time setup. As KiCad then refers to the libraries by name and not complete file path this works great.

The issue i am having is with the assignment of 3D models as the step files are not saved with the footprint itself but is a referenced extra. Currently i have the 3D model file path as → C:/Users/username/SharePoint address/3dmodels/filename.step the issue being the ‘username’ section is different for each user and so the model does not get automatically pulled across. I have tried using a wildcard in here such as the file path becomes C:/Users/%USERNAME%/SharePoint address/3dmodels/filename.step but KiCad doesn’t appear to be able to resolve this file path.

Is there any plans to incorporate the 3D model into the footprint file itself so that it handled directly in the library file?
Alternatively are there any other suggestions on how to handle the wildcard file path or alternative suggestions to handling this SharePoint link?


Windows supports symbolic links. Could you create a link from a standard location to the 3D directory in the users SharePoint mount?

I don’t understand where you problem really is. Here it is how it looks like on my computer:

  • Footprint MiniFit-2Pol contains 3D model named 001:MiniFit-2Pol.step
  • When i click on Pfade konfigurieren ... (configure paths), i see 001 is listed as /path/to/kicad/3d/models.
  • The variable 001 is defined to /path/to/kicad/3d/models, in the users home directory $HOME/.config/kicad/3d/3Dresolver.cfg (no idea what Windows uses for a path, but you should find it somewhere), so it can be different for each user.

Does it look different on your system? If not, you have to assign each used folder (your should be able to get away with just one) with 3D models, for every user once. Once you setup a user, it should continue to work for new models and with different users, with the same library (.kicad_mod) files. This works in KiCad 5 and KiCad 7.99, i assume it should also work with KiCad 6 and KiCad 7.

1 Like

Thanks! that has managed to point me in the right direction and solved the issue! i was originally associating a discreet file path (C:/Users/username/SharePoint address/3dmodels/filename.step) to each footprint which is why i was having the issue.

By configuring a new file path named SHARED and directing that to C:/Users/username/SharePoint address/3dmodels/ i am now able to just point each footprint to SHARED:filename.step and that is working perfectly.



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.