Setting Grid Thickness

I have a problem with setting the grid thickness. I had initially installed KiCAD 6 and changed the grid setting in the schematic editor, whereupon the points were displayed in 10 px. Back in the settings, the button “Reset display options to default values” was inactive. I could no longer change the setting. At first I thought this was a bug and that it would be ironed out with an installation of version 7. So I installed version 7. When I click the button “Reset display options to default values” in this version, the value is reset to 1px. But as soon as I leave the settings, the setting falls back to 10px.

Thank you very much and best regards.

Hello and welcome @Smorrebrod

Did you press the “OK” button after the “Reset display to default values” was pressed?

Yeah, sure. Unfortunately, it’s not that trivial.

Would you post your Kicad version and OS please.
Go to: Kicad / Help / About Kicad / Top LH corner click “Copy version info” then paste into a post.

Application: KiCad Schematic Editor x64 on x64

Version: (7.0.0), release build

wxWidgets 3.2.1
FreeType 2.12.1
HarfBuzz 5.0.1
FontConfig 2.14.1
libcurl/7.83.1-DEV Schannel zlib/1.2.13

Platform: Windows 10 (build 19044), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Feb 12 2023 01:35:19
wxWidgets: 3.2.1 (wchar_t,wx containers)
Boost: 1.80.0
OCC: 7.6.2
Curl: 7.83.1-DEV
ngspice: 39
Compiler: Visual C++ 1934 without C++ ABI

Build settings:

Can you return to grid 1px. using the - button or are you stuck with the 10px?

I cannot replicate your problem BUT I’m using a Linux version of 7.0.0.
There also seems to be no reports on Gitlab regarding your problem.
Sorry, I can’t help, but others using Win 10 may be of assistance.

You may have to wait a little while for Europe and the US to wake up.

The value 10 always remains in the input field for the grid thickness. The buttons to the right of the input field (increase/decrease value) do not react. When I click the button to restore the default values, the value is reset to 1. But as soon as I confirm with OK and exit the settings, the value is set to 10 again.

What else is strange: In version 6 the button to reset to default values is inactive, so it can’t be clicked.

Thank you anyway very much.

I noticed you were translating to this forum.

I believe there have been a number of problems with translated Kicads. In what language are you running Kicad? This may be of help to other members who will enter this forum

I have just edited the “eeschema.json” file in the KiCad 7.0 directory and set the value “line_with” to 1 (it was set to 10), saved it and restarted KiCad. The grid is then back to the default value of 1. So okay. As soon as I change the value, the symptoms described above appear again. It is also not possible to vary the value with the up/down buttons to the right of the input field.
“display”: 0,
“grid”: {
“axes_enabled”: false,
“fast_grid_1”: 1,
“fast_grid_2”: 2,
“last_size”: 1,
“line_width”: 1,
“min_spacing”: 10.0,
“show”: true,
“sizes”: [
“100 mil”,
“50 mil”,
“25 mil”,
“10 mil”,
“5 mil”,
“2 mil”,
“1 mil”
“snap”: 0,
“style”: 0,
“user_grid_x”: “10 mil”,
“user_grid_y”: “10 mil”

My language setting is set to German.

Hello I’m experiencing exactly the same behavior, any news about this?
Actually I just realized that is enough to open settings and apply them to mess up at least all grid width (or thickness) in ALL the editors…

1 Like

After several hours I think I found a reliable solution…
In my case I fixed by changing regional settings, language and separators.
It was set somewhere Italian, somewhere else English and once I realigned everything to English everything started working fine again!


Thank you very much! I have now also solved this problem by changing the language setting. Without your hint I would not have come on it.

Happy that it was useful to somebody else!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.