Setting grid size in schematic

Hello!

This time I’m in 5.1.9, Linux Ubuntu 20.04 native (no virtual box).
I have the following problem: for some reason, one of my symbols got shifted by about half a pitch horizontally (see below). I thought it might be a grid size issue, but I don’t find any way to set the grid size in eeschema. Is there a way to fix this? I suppose it’s possible by hand in the source file, but I would prefer the source files to be written by Kicad only.

Thanks for any hint.

Screenshot from 2021-02-20 15-55-39

Hello again!
I just reply to my own post in case it can be useful to somebody else. There is a grid setting for the schematic, but it’s not in the preferences, sheet settings, eeschema settings, etc… There is a menu here:
View -> Grid settings.
That’s it!

Hello Roboya,

View, Grid settings.

Change your grid to 25 then move the whole block half a “pitch”.
Don’t forget to change the setting back to 50 afterwards.

EDIT: the late JMK finally arrived :slightly_smiling_face:

On second thoughts, maybe it should be the early jmk for you North American and European types.

Hello JMK!

On second thoughts, maybe it should be the early jmk for you North American and European types.

Must depend on where you are. I’m in Japan (Kyoto).

Australia here. Much the same time zone as you.

Most of the forum dwellers will be tucked up in bed at the moment.

6.30 PM and I’m sitting in front of my computer messing around with my kicad libraries because it is still too hot to do anything outside.

Hi
You can also right click > Grid > Sizegrid

Hello!
That’s good to know!
Thanks!