Setting copper zones inside other copper zones


#1

Hello everyone,

I’m trying to setup some copper zones inside copper zones while setting the inner copper zone to have a higher priority(Don’t know how) and when starting to do that the DRC pops up with an error message saying I can’t do that what do I do?

Thanks for the help in advance.


#2

In the zone properties (press e when above the zone outline) there is a setting called zone priority.

Higher numbers mean higher priority


#3

Ideally you want your main plane that you are excluding to be generated last, so it would have the lowest priority,

The smaller planes that you want inside you would want to be generated first, so they get a higher number. so that when it reaches the surrounding plane, it knows to exclude that area, and does not overlap 2 planes.


#4

Well Thank you that helped!


#5

What about what Rene said? you could change this anytime you want.


#6

yes, just right click on the edge of the zone, and select zone properties, there will be a priority setting that defaults to 0.