Setting Coordinate Origin

I found only a few stale entries on this. I am doing some precise header placement for stacking boards and I need to set the coordinate origin on each board. I played with the “set origin point” icon but I don’t see any change in the coordinates shown at the bottom of the editor.
Also I notice that the default origin of the page margin for pcbnew seems to be off high an to the left of where one would expect.
Can anyone enlighten me here?


1 Like

Grid origin doesn’t affect the coordinate system in any way. It just starts the grid from that point. You can’t change the coordinate system of KiCad.

@RRPollack was doing some work to enable changing the coordinate system but he has been silent and it won’t be until v6 anyways. See

1 Like

If you want to stack multiple boards, such as with PC104 style, then consider to make a template project with the board outline and connector layout.

Also, if you hover over a footprint in Pcbnew and hit [E] for edit, you can directly type or paste coordinates for a footprint in it’s properties window.

If you’re unlucky however, you may have problems with diffferent offsets for male and female connectors or a rotated connector.

Thanks Paul.
these are boards attaching to a main board–unlike the PC104. With other products I used in the past I would move the coordinate zero to one “main connector” pin on the main board and then set up the daughter boards with the proper offsets so all the boards fit in the end. I use the coordinate settings as you mention to get the initial connector positions.
Whatever the case I always print-actual-size sheets of each board and a check alignment with sewing pins setting them on a “white” layout board.


Another very simple tip is to put all “important features” such as connectors, board outline & mounting holes on a coarse grid (0.1" is often used).
This ensures it either fits perfectly, or errors are big and easy to spot.

This also makes it easy to make an experimental add-on board from 0.1" Veroboard.

1 Like

I’ve been working on a personal project and KiCad pre-V6 was not stable enough for my comfort, so I’ve been maintaining a private set of V5 patches that implements the same behavior.

I do intend to get this functionality into V6 before it releases.

I’m not sure what is exactly your problem but moving the coordinate origin to a specific point at PCB is the same as moving whole PCB such that this specific point will be at coordinate origin. Many my PCBs are in some way symmetric so I decided to have coordinate origin in middle of my PCBs.

The problem is this:
I design a board centered on the page margin and it has a key connector/header that needs to align with other similar board connectors in a layered structure. Normally I would center the coordinate system on pin zero of said connector.
I suppose I could “let the dog wag the tail” so to speak, and place pin zero on the defaulted orgin using trial an error to get it placed right. But there is a further issue–for some reason when I start a new board the coordinate original falls off the margin at 0.45, 0.45. I don’t see an option in the board or page setup to move it.


I’m not at the computer with KiCad. You can check the position of your connector, and use precision move operation (entering by keyboard the offset to move). Tried that long time ago - not sure if I used the right name.

I was surprised seeing the page frame at PcbNew screen. I’m not sure but probably it was just impossible in PCB designing program I was using last 20 years. Fortunately you can define your page frame to be empty (not sure - when I was experimenting with it it was not possible (you had to left at list one line (I left a X/Y small cross at 0,0 position)) - in 5.1.5 probably possible).
After (about 1.5 year ago) defining it that way I just forgot of page frame and have everything back ‘as usual’.
We have never printed PCBs ‘in scale’ but always ‘as big as possible at A4 page’ - easier to rad as to place the names and references inside 0603 and 0402 we use 1mm high text.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.