Setting a custom page layout as default


I’ve created a black boarderless page layout in layout editor and saved the file and I’d like to set it to default in PCB new how’d I do this?

Thanks for helping.

For a project, in File -> Page settings, at the bottom select the “Page layout description file”.

To make it the default for new projects,

  • edit the project template “” (mine is in C:\Programs\KiCad\share\kicad\template)
  • find the section [pcbnew],
  • change the line PageLayoutDescrFile= to add the path of your custom layout

OK thanks noticed it just now but when I load a blank one in the boarders still appear do you know why?

Yes, it’s a bug, if there are no elements in the layout file KiCad uses the default file instead.

As a workaround, add a graphic line with zero length somewhere.

Ok yes that works thank you but I still have those boarder lines also what I’m trying to achieve is when I import a DXF file for outlining I wanna have it’s vectors XY positions to match the ones on the layout.

Maybe you are referring to the page limits? Preferences -> Display, Show Page Limits.

Sorry my fault when I import it I usually select the centre of the page(apparently is not 0,0 XY) instead of upper left corner, fixed now thanks for all the help realy!

1 Like

Where can we find a list of all the possible line items that we can define in the project template file?

I don’t know, I’ve never seen such a list.

Do you mean


Hi, I’m running version 4.0.5_dfsg1-4 on debian.
I did a grep for PageLayoutDescrFile in /usr/share/kicad/ and cannot locate any file containing that variable.
I opened /usr/share/kicad/template/ and added the variable under both [pcbnew] and [eeschema] but to no avail.
I’ve done a work around by creating a default directory and copying that when I need to start a new project, I’m just curious to see what I’m missing?