Selectively show ratsnest?


#1

Is it possible to show some ratsnest lines? For example, two “settings” options that I’d find useful are:

  • Show only the lines that are entirely contained in the screen (in the “view port”)
  • Show only the lines that connect to the specified footprint(s)

Is it possible? (either the above or something similar to avoid overflowing the screen with ratsnest lines when I want to work and focus on one section of the layout)

I’ve noticed what looks like an “accidental feature” — if (as in, only if) I click on the “Show board ratsnest” button to enable them and then again to hide them, then while moving a footprint (or set of selected footprints), the lines that connect to it/them show and remain showing while the selection is active; then they disappear as soon as I click anywhere. This is useful, but IMO not enough (aside from the fact that it looks like accidental behaviour (it doesn’t work like that if I just opened pcbnew with the ratsnest disabled).

Thanks,
Cal-linux


#2

Sadly right now there is no way to restrict which ratsnest lines are shown. The only option is show all or none (button in the left toolbar)

There are plans to add a powerful ratsnest manager. At the earliest this can be in v6. An example wishlist item on the bug tracker would be: https://bugs.launchpad.net/kicad/+bug/1740156 and another one https://bugs.launchpad.net/kicad/+bug/593962


#3

I don’t think this was in the bug reports, so you might want to comment there.


#4

What do you mean? The above is what I would include in the “wishlist”, not something related to any bugs (did I misunderstand?)

Cal-linux


#5

Launchpad has “bugs” feature which includes wishlist items, the latter are just tagged by developers differently. Sometimes it’s easier to talk just about bug reports even when they aren’t bugs. In more advanced issue tracking systems they are all “issues”. If you read the above mentioned “bug reports” you see they are wishlist items.


#6

There is a third option: select show none with the left toolbar button and then use “show local ratsnest”, the 3rd button from top on the right toolbar.

Use: select the tool and click on a pad/footprint


#7

I missed this tool as it has always been on the left toolbar. Did not notice it moved. (All other visibility buttons are on the left so this is very strange button placement.)


#8

In fact there has been a different change. It seems “show footprint ratsnest” has been removed from the left toolbar. And the old “show local ratsnest” on the right behaves now as the footprint ratsnets. Finally, the old function show local ratsnest that showed the connection of a single pad has been removed.
I don’t know why because it was very useful.


#9

I think the old stuff only worked in legacy canvas.


#10

Seems like a rather unpolished feature. I suspect I will still use it often enough. A couple of (arguably-)issues I’ve identified:

  • If I have the ratsnest disabled (i.e., when I launch pcbnew the board comes up showing no rastnets lines), the feature only works if I enable it and then disable it back.
  • After I selected one footprint, it stays on, and if I select another one, it shows the superposition of both footprints’ ratsnest lines — this is not in itself a bad thing; but it’s a bit of an odd behaviour: if, having unselected a footprint I go and click again on the “show local ratsnest” button to click on a different footprint, it seems intuitive that I want to replace, and not add; for adding, I expect that I should consecutively click on several footprints after the “show local ratsnest” button.
  • [edit – just remembered another one] if I’m showing the ratsnest because I want to decide how/where to place a footprint, then the “show local ratsnest” for that footprint is useless; after having enabled→disabled ratsnest, now just moving a footprint causes the ratsnest lines that connect to that footprint (and only those) to show. Again, this all feels like rather accidental features.

Thanks,
Cal-linux