Selection of all Testpoints on the PCB

I am using Kicad 7.0.6 and need to copy all the testpoints in my layout to another PCB to create a testbench.
Earlier with Kicad 6 this was simple, my Testpoints all have a circle in user layer 1 so I just deactivated all layers but userlayer1 and pressed ctrl+A, then all the testpoints were selected and I could copy them. With Kicad7, pressing ctrl+A does not select anything as long as the copper layer is not visible… I don’t fully understand what changed here, as I can not select anything on userlayer1 anymore.

however, is ther a quick way of selecting all the testpoints at once with Kicad7.0.6?

I’m not so sure about your selection method. It smells like a “Happy accident” that it selected footprints instead of just graphic items.

I did a (little) bit of experimenting.
It sure could be nice if there was a “Select all” button added to: PCB Editor / Edit / Find

Note the Hit(s): 3/6 at the bottom of the dialog. It has currently the third of the 6 found testpoints selected.

This (new?) feature may be worth a feature request at gitlab.

As a workaround you can make a copy of the PCB (or backup, or exit without saving, etc) and then just delete everything that you do not want. But it is a quite kludgy workaround.

Interactive HTML Bom has functions to for example “highlight all 100nF capacitors”, and it’s meant as a PCB assembly helper program. It probably can’t export a part to KiCad or anything like that.

thanks for your reply. yeah, the manual option of course is possible, but it takes long (we sometimes have hundrets of testpoints) and sometimes you make mistakes.
the “select all” button would be awesome. Not sure how to make feature requests, and it also will take long for implementing I guess… do you thing there would be an easy snippet for the python terminal to select all testpoints?

It probably can be done with a handful of lines of python, but I never looked into the scripting interface myself.

there was a gitlab-issue recently regarding the selection-behavior in dim/single layer display mode. (see Cannot select graphics-only footprints in single-layer view modes (#15284) · Issues · KiCad / KiCad Source Code / kicad · GitLab). So it could be that your described selection behaviour returns back. (you could check with one of the latest v7.99-nightly builds).

Nevertheless, you could use also the inbuilt search-panel:

  • assign all testpoints a unique name: for instance TPxx (must be different letters than other symbols/footprints)
  • open the search-panel: pcb-editor–>view–>Show search-panel
  • open the “footprints”-pane
  • type “TP*” into the filter-box: now only your testpoints should be schown
  • with click you select one footprint from this list, with Shift+click you select a range of this footprints list
  • now do what you want with this selection
1 Like

thanks mf_ibfeew, this indeed works! cool, I never used this search panel, did not even know that it exists :smiley: now it works fine, thanks a lot


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.