Selecting pin selects the whole connector

Hi all I am new to Kicad and I am working on my first PCB layout using this software. In Pcbnew when I select a pin of my D-Sub 50 pin connector it selects the whole connector. For instance I would like to select pin 3 edit the properties and tell it to bind that pin to layer # 3 which is my ground plane. I would do this routinely on Mentor Pads but can’t figure it out how on Kicad Pcbnew. I am using Ver 5.1.5


Ground planes are added by use of zones not via some layer property. Connecting to that zone is done via the connectivity information that you get from the schematic (by use of the net name of both the pad and the zone).

If the pad is a smd pad then you will need to use a via to connect to a zone on a different layer.

See How to create a power plane (using zones)

Hi, thanks for the reply. I did create the ground plane already but can not associate the ground plane to the appropriate pin numbers on the connector. When I try to select a pin number the whole connector is selected.


Do you work without schematic?

I have captured the schematic already.

I assume the symbol that represents your connector has the pins in question connected to the ground net. I further assume that the zone is connected to that ground net in pcbnew. There is then no need to touch the pad properties as this is all that is required to create a connection.

Of course if the zone is on a layer that is not present in the pad then you will need to use a via as explained above. Also be aware that zones have their own clearance settings so it could be that the connection is just not made because the zones clearance is set too high.

Maybe a screenshot of your connector would clarify your problem.

There seems to be a misunderstanding here…

Also, I do not see the design flow of “editing the properties of a pad” to connect it to a GND layer.

Normally when drawing the schematic (in Eeschema) it generates a netlist, which already has that information in it.
Then in PcbNew you draw a “Zone” and you assign that zone to one of the nets in your netlist. This is probably the step you missed.

To what net is your corrent “GND Layer” connected?
(In KiCad I usually draw a “zone” which is bigger than the PCB on a layer if I want the whole layer to be a GND plane).

What does it look like if you hover over your zone, and then press ‘e’ for “edit”?

This is very strange now Pcbnew is behaving as I was expecting it to and I can select individual pins for my connector. The issue was that I could not select individual pins, whenever I clicked on a pin it would highlight the whole connector. However now it is working correctly.
Thank you!

Did you play with the footprint’s Properties? If a footprint is “Locked” the individual pads can’t be selected.

I still wonder what good selecting single pads does in the context of the overarching question. The feature described from Pads is simply non-existent in KiCad.

I can select a single pad in pcbnew press ‘e’ and assign a net to that pad.
Totally the wrong way of doing things but it is possible.

Application: KiCad
Version: 5.1.5-52549c5~84~ubuntu19.10.1, release build
wxWidgets 3.0.4
libcurl/7.65.3 OpenSSL/1.1.1c zlib/1.2.11 libidn2/2.2.0 libpsl/0.20.2 (+libidn2/2.0.5) libssh/0.9.0/openssl/zlib nghttp2/1.39.2 librtmp/2.3
Platform: Linux 5.3.0-40-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.67.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.65.3
Compiler: GCC 9.2.1 with C++ ABI 1013

Build settings:

Why? …

Assigning nets in pcbnew is not really a good idea. The schematic is the documentation of your product, assigning or worse changing net assignments in pcbnew will make the documentation invalid. And the technical reason is that the next update from the schematic will simply remove that info.
@MichelleG stated that they have a schematic so there is no reason at all to do it in the pcb. (I mean yes it is possible but why not do it in a future proof way?)

If the schematic is captured already, assigning pins manually in the pcb layout did not seem like a good idea.

Ok, so here is a screen-capture of the board I am designing. The purple layer is the ground plane which is selected here. As you can see the net is GND and you can see pin 14, 31, 48 are GND but pin 31 even though is assigned to the GND net it looks like its floating. So my question here is how do I connect pin 31 to the GND plane?

I would run a tracks manually from the neighboring pins, does the erc caches the error?

The combination of minimum width, clearance and thermal spoke settings of your zone do not permit there to be a connection. Play around with these settings until you are happy with the result.


Great! This actually worked.
Thank you

And to add a small detail, the ability to assign a net to a pad is probably a side effect of a D_PAD being of type “BOARD_CONNECTED_ITEM”. TRACKs (and VIAs, a type of TRACK) are also BOARD_CONNECTED_ITEMs, as are as ZONE_CONTAINERS, and those do need the ability of assigning nets.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.