Selecting just components in PCBNew - how?

Nearly every time I try and select a footprint I get a clarify selection pop up asking if I want the footprint or the pad or the reference text etc. I can’t find any type of checkbox or filter to turn this off. I ONLY WANT TO SELECT FOOTPRINTS.

There must be an easier way and I’m probably just dumb and can’t find it. Please, can somebody explain to me how to accomplish this? I can’t imagine anybody would work this way, checking a ‘clarify selection’ box every single time. :weary:

What KiCad version you are using?

I’m on version 5.1.5

My solution is to hide Values and References (using right panel).

That helps a bit. In general, learn to use the Layers and Items visibility. And the High Contrast mode. And also the box selection where you drag a box, and dragging left and right are different. Together these will make selecting wanted things relatively easy, although there are still situations where you have to hit exactly a right spot to hit something wanted and avoid unwanted.

The difficulty of selecting things in a complex layout is acknowledged. In the development version we have the selection filter, see Post-v5 new features and development news. It won’t help you until v6, though.

1 Like

FYI - you can Right-Click and set Selection & Filter…

1 Like

Yes, that filters afterwards, i.e. removes the uncecked items from the selection. The new filter in 5.99 filters beforehand (or while selecting, if you prefer to think it that way).

Unfortunately even when references are hidden the clarify selection still asks you if you’re trying to select them, which seems like a bug.

Very much looking forward to that selection filter in the next version. I’ll read up on the High Contrast mode. The left/right select dragging is definitely helpful.

One issue I continually run into with dragging however is, if I have a large footprint part say on the other side of the board that’s locked, and I’m trying to grab and drag smaller components that are in the same 2 dimensional space but on the other board side, I keep getting a pop up message telling me that I’m trying to select locked parts would I like to continue. I think locked parts should be left out of drag selections.

I’m making the switch over to Kicad from years of using FreePCB. Don’t get me wrong, PCBNew is light years ahead of FreePCB in terms of capability, but selecting parts in FreePCB is so intuitive and effortless. You always get what you click on. Sometimes you might have to click twice to select a ref designator for example if it’s inside a footprint but it’s so much quicker and easier to just double click than have a context menu pop up every time.

As I remember there were many bugs in 5.1.5. I switched to 5.1.6 to be able to generate SVG files for Bottom layers. May be there was also bug you are having a problem with it now.

Actually yes, I just updated to 5.1.6 and now it doesn’t seem to ask to clarify about selecting text when references are hidden. Thanks for pointing out the update!

1 Like

I’ve always found the easiest way to select a footprint first time, is to find a part of that footprint (doesn’t matter if it is a Pad, CrtYd, Silk, Ref, or Value) with nothing underneath, then zoom right in on that spot, draw a small block (bottom right to top left, the blue outline box) so it at least touches that part of the footprint and you’ll find the the whole footprint selected.
This doesn’t work by drawing the box from top left to bottom right, the yellow outlined box.
I also find this process easier with the centre and warp cursor “on” (see preferences, common).

Just an update to this for anyone who may be having the same problem… Some of my footprints had very large courtyard layers and that was making selection difficult when they were close together.

Also I learned about using High Contrast Mode (Piotr’s advice) which makes it so only parts on the layer you’re currently routing on are visable which helps a ton. So that’s what I was missing, selecting parts is so much easier now. Thanks all!