Selecting footprint does not always save

Application: KiCad Symbol Editor x64 on x64

Version: 8.0.3, release build

Libraries:
wxWidgets 3.2.4
FreeType 2.12.1
HarfBuzz 8.3.0
FontConfig 2.14.2
libcurl/8.5.0-DEV Schannel zlib/1.3

Platform: Windows 11 (build 22631), 64-bit edition, 64 bit, Little endian, wxMSW
OpenGL: Intel, Intel(R) UHD Graphics, 4.6.0 - Build 31.0.101.1999

Build Info:
Date: Jun 3 2024 19:04:47
wxWidgets: 3.2.4 (wchar_t,wx containers)
Boost: 1.83.0
OCC: 7.8.1
Curl: 8.5.0-DEV
ngspice: 42
Compiler: Visual C++ 1939 without C++ ABI

Build settings:


Problem: I open a symbol and then choose a footprint through the symbol dialog. About 75% of the time when I double-click on the desired footprint the dialog window closes without an update to the symbol information. This also occurs if I single-click on the footprint then click OK in the dialog window. This is occurring with both networked and local libraries. This is occurring on multiple installs (Windows 10 as well).

If you are assigning footprints to symbols, I would expect to see Application: KiCad Schematic Editor or Application: CvPcb here depending on which window you got the help dialog for. Are you using the correct tool? It’s Schematic Editor > Tools > Assign Footprints. Post a screenshot of what you are using.

You could also be trying to assign a default footprint to a symbol. Some people do that for convenience if the symbol is used a lot and that footprint always associated with that symbol. To be able to do this the symbol library needs to be writable. The standard KiCad libraries are read-only so you need to make a copy of the symbol in a personal library first.

FYI - I can’t comment about other Computers and Settings… I use a Mac.

In the Footprint Editor, for example, if I have previously selected and opened/edited a footprint then, I select a different footprint and click ‘Save’, it’s not the currently selected footprint that gets saved - it’s the one that was previously Active/edited (the one in Light-Blue), not the one in Dark-Blue.

And, that also applies to Delete (I learned that the Hard Way !)

Is assigning footprints to symbols in the Symbol Editor an incorrect way to use the tool? That seems counterintuitive to me.

Regardless, I’ve seen it occurring when attempting to save the footprint from the Schematic Editor as well.
My process is to:

  1. open the symbol properties
  2. click on the Footprint field
  3. Click the icon to open the Footprint Chooser.
  4. Scroll to the desired footprint.
  5. Select the footprint.
    I’ve tried different combinations of double-clicking the footprint name, single-click to ensure the footprint is highlighted followed by either double-clicking the name or selecting ok in the window. The behavior occurs regardless if the footprint field was previously populated. I only noticed this behavior starting in 8.0.3.

@BlackCoffee this is occurring with footprints that have been confirmed saved to the local library. On Windows changing to a different footprint brings up a dialog to save/revert changes to limit that problem.

See the last paragraph in my amended post.

There are 2 symbols you could be editing, the copy in the schematic or the original in the library, which could be unwritable. Generally people use Tools > Assign Footprints as that’s faster since it presents all the symbols in tabular form.

The footprint and symbol libraries in question are custom, are they are saved in locations that do not have read/write limitations. (Network and local drives)

E: I only mentioned the schematic editor because it was asked. I was originally working in the Symbol Editor which doesn’t have the Assign Footprints tool. The bug is present in either case.

Attached is the image showing the steps that I follow.

Three may be some subtleties with network drives. For local drives I’ve had no problems editing symbols in personal libraries. :person_shrugging:

Another caveat: if you are editing the default footprint in the symbol in the library, it will not appear in the schematic’s copy until you refresh (update) the symbol from the library.

No.
The same Symbol Properties panel is accessed for a symbol, whether that symbol is in the Symbol Editor or the Schematic Editor.

Your above method is the normal for assigning footprints via the properties manager. Unfortunately, I have never experienced your problem either.

Maybe try using Tools > Assign Footprints to see if the problem still exists. If it does, try to see if the problem is with network, local or both.

I have also not seen this problem myself. I also do not use network drives and have seen multiple bugs around these things.

Does this happen only in this project, or also in other projects?
Does this also happen in a project where none of the libraries (even unused) are from a network drive?

@jmk I am able to use the Assign Footprints tool without complication thus far. Its not the ideal solution, but it is workable.

@paulvdh I have observed this behavior with separate projects that had all of the custom libraries contained within the project folder on a local drive.

I am seeing this exact same behavior. When editing a schematic symbol, I assign the footprint quite often from the selection field. I have seen this in 2 different projects, in both linux and in windows, both updated to 8.0.3. In this example, when I click the library to bring up the dialog (next to SOT26 in this case), and double click SOT26 so that it should read mheld_std:SOT26, it just goes back to “SOT26” (without library specification). Repeating a second time made it work. I tried various iterations of having it start with a library specification (e.g. “mheld_std:SOT26”), without, with completely invalid footprint names (“SOTBLEE” and “mheld_std:SOTBLEE”), and it was still about 50% hit or miss, with no real reason or indication as to why the field wasn’t getting copied over.

Note: This also occurs for me when using the bulk fields editor.

This has already led to a lot of confusion for me, because I select a footprint, and when updating the PCB, it complains the part has no associated footprint, and I’m left scratching my head going “No, I know I selected a footprint for that… what the hell?”

As a bonus, if this will post, I can link a video of what it does for me. Again, I’ve seen this both linux and windows, but for this I’m showing in windows (10).

http://dione.net/2024-07-16%2007-45-35.mkv

This is exactly what I’m seeing!