Segfault at 58 .. in _pcbnew.kiface


#1

Hello , my name is joerg, im very sorry about my english… I hope you can anderstand my reading.
I use kicad aproc. 1 Year. now i create some drawing, make my liberis, and my wrl (3D) fils with freecad.

My Version Is

snip
Application: kicad
Version: no-vcs-found-1e87ae6~58~ubuntu16.04.1, release build
Libraries: wxWidgets 3.0.2
libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-81-generic x86_64, 64 bit, Little endian, wxGTK

  • Build Info -
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.58.0
    Curl: 7.47.0
    KiCad - Compiler: GCC 5.4.0 with C++ ABI 1009
    Settings: USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON

/> snip

my system is linux mint, kde,

snip Linux X200-KDE 4.4.0-81-generic #104-Ubuntu SMP Wed Jun 14 08:17:06 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
/> snip

for ruffly 3 days, i start with same problems while running kicad. …
When i update the netlist ( createt in Eeschema ) , and in Pcnew start to read the netlist, ( after klick the ok button from the Warning ) The hole kicad is kiiled.

in demesg i got the message :

snip
153.929937] kicad[2351]: segfault at 58 ip 00007ff87c3d1081 sp 00007ffe5c4edeb0 error 4 in _pcbnew.kiface[7ff87babf000+fe7000]
[ 780.372658] kicad[3448]: segfault at 15100000058 ip 00007f347914a081 sp 00007ffc26f47cb0 error 4 in _pcbnew.kiface[7f3478838000+fe7000]
[ 1762.132338] kicad[3726]: segfault at 58 ip 00007f9048fa3081 sp 00007ffdb63b29d0 error 4 in _pcbnew.kiface[7f9048691000+fe7000]

/> snip
so… mayby there is a problem in the php or someting else…

i start kicad in a konsole
first of all i see a message “(kicad:3819): Gtk-WARNING **: Im Modulpfad »adwaita« konnte keine Themen-Engine gefunden werden,”

hmm…

after open Pcbnew , and try to read the netlist, i got " (kicad:3854): Gtk-WARNING **: Im Modulpfad »adwaita« konnte keine Themen-Engine gefunden werden,
Speicherzugriffsfehler"

is there anybody to help my?

i try to run my linux withe “old” kernelversion, and without the nvidea driver, still the same problem…

Anayn, im very sorry about my poor english…

Regards, Joerg

If there is anybody whith furter questions, pleas ask my …


PCBNew segfault
#2

Do you have gtk-theme-config installed?


#3

i have install it, i make a update, try to purge the hole kicad, install it
again with the ppa, still the same.
when i rename the pcb file to filename.pcb_save, the kicad ask my to create
a new pcb. after insert the netlist, i can work for about 10 'moves" , then
still the same.

im not shur, when i open a new project, or an old project, everthing is
working… so mayby i have a problem in my libs or pretty files?

if ther is a posibility to fibd out whats wrong?

regards, jörg


#4

Is this the same issue as https://bugs.launchpad.net/kicad/+bug/1700269


#5

Yes, i think so, i habe read the posting from bug 1700269…
maby it helps when i compyl kicad from sourccode…

I try this tomorrow…

I find out same realy strange thing…
1.) I open kicad, make same cange in the drawing…
2.) Build a netlist. -> crash

then again… ( i try this 20 times !!! )

1.) Open kicad, make same canges (its enought to change the footprint from a symbol )
2.) I save the schematic.
3.) open it again, Build the netlist, -> Now its working!! hmm

but when i change a footprint , whitout saving the file ( befor crating the netlist ) crash…

i can see also same phenomen…
i work with 2 Monitors, ( left the schematic right “projectfie” and the layoutprogram)

when i change a footprint in the schematik, and i save the file, befor i build the netlist,
then the “icon” from the Schematik file is gone…

sorry, its not possible to my to insert two pics. i put 2 scrrenshots together.

Mayby this is helpful…

regards, joerg


#6

This bug was fixed last week. Can you try the nightlies again and see if your issue remains?