Scroll with Mouse - wheel action - zoom in and out

I used many many CAD programs over the years Since 1990.
The way the program lets you navigate the design is FUNDAMENTAL in its success.

The BIG issue for me in Kicad is the basic zoom function with the scroll mouse.
It stands in the center of everything to do with using the program.
I does not behave like other CAD programs. Take Eagle Altium or Diptrace for instance.
They work intuitive. Even Mechanical CAD programs behave the same intuitive way.
Not Kicad, at least not on default settings…
It is VERY frustrating and DEBILITATING.

The main issue seems that it is programmed to jump the cursor from where you point and then start to scroll tot the center of the screen. We, that try to use Kikad, need to at least be able to disable that feature under Settings…

So where do I find this setting?

1 Like

Preferences | Preferences | Settings | Pan and Zoom

Thanks so much - swift reply at that!

Preferences | Preferences | Settings | (under Common) Pan and Zoom
un-tick ‘Center and warp cursor on zoom’

It works! Beautiful!!!

1 Like

While the center and warp functionality might seem strange at the beginning, I highly suggest you keep it active and give it a try. It will take a bit of getting used to but at some point in time you will no longer want to work without it. (Navigating the canvases of both eeschema and pcbnew will be a lot more efficient as you can pan and zoom with one action.) This might however be something where you get used to everything else first and then get back to this feature once you feel you are ready.

When 2 years ago I first time tried KiCad and noticed that behavior my first think was “It is genius. I need only mouse wheel to navigate. Why other programs don’t work that way?”

2 Likes

Most programs people use would not really benefit from that feature. I is only CAD programs that do. And in all honestly mostly 2d cad programs.

The problem is - that if you are new to Kicad - this feature enabled hits you like a brick wall.
I am used to 3D CAD for 30 years, this feature are unneeded for me. Absolutely.
It only made my older eyes get very weary and even seasick. But I am sure others my find it handy.

Preferences->Common->Center and warp cursor on zoom checkbox.
T.

Already done. See post number 4.

I think the argument @twl is trying to make is that it might not be the best choice to have this as the default. And maybe they have a point here as there are very few tools using this type of feature. It might really be something users should deliberately choose if they want to improve their productivity instead of being surprised by the strange behaviour (new users might not even know the term to look for, so they might never discover how to turn it off).

1 Like

If it was not default I would probably never find this genius feature. And if even after some time I would find it I would be probably so used to default that I would see it as disturbing me. I think it should be default to give users a chance to accept it. If someone notice something works wrong for him he will certainly search to switch it off.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.