Schematics are all question marks

First, thanks for providing this tool. However, I just upgraded t the most recent version of Kicad and nothing seems to work. My schematic, that was fine in 4.x (in fact I got gerber file and pcbs from the data). I now get a library error and my schematic is filled with question marks. It seems all links to libraries are gone. The links are missing to my custom parts as well as standard parts like resistors and capacitors.

I am afraid to open any other schematics because of these issues.

Again, thanks for your efforts. Please advise.

Gman

The reason you get question marks is twofold. You have now different libs (after the update) and your projects cache library is not preserved.

For the importance of the later read What are the cache and rescue libs and how does the schematic rescue dialog work?

And as your project was made with v4 libs: Converting KiCad version 4 projects to version 5 (Remap a project)

You can disregard the link by @hermit as that one only deals with footprints not symbols.

I tried to remap the first time but I believe I got an error message. Things went south very quickly and I cannot claim I recall all the events exactly. BTW, I can still place new components on the schematic from my custom libs and the “Manage Symbol Libraries” pick item still lists my lib and other libs. All libs are labeled “legacy”. Libs are listed under project and global libs.

Tried the rescue but got a “nothing to rescue” message.

I suppose the remap message happens only once. I do backup my projects weekly but did not backup this project before opening the schematic.

Do I have to re-enter every component? All the wire connections appear to be in place. I am concerned that even if I re-place each component manually the fact that all libs are labeled “legacy” will cause further issues.

Do I have to delete all the legacy libs from the both project and global entries?

Thanks for your assistance.

Downloaded the zip file. Ran it. Tried to remap but still get question marks on the schematic.
Thanks again

Reloaded all the files. Each project is in its own directory so I downloaded the dir from my backup. This time the remap appears to be working. I still don’t know what happened. Current hope is that it is my pilot error.
Thanks again to all.

Remap can be a tricky process. It is unforgiving but luckily (in version 5.1.x) creates reliable backups before it does anything. A very important thing is that you really need to have the cache lib present and valid in the project before you can start the remap process as it is essential for a successful recovery.

There are ways around this described in my tutorial, but they require you to know which lib version was used and also require you to use a text editor to edit the project before you start the process