Schematic view vertically flipped (Resolved)

Hello,
I have just installed KiCad for the first time ever!
I’m attempting to follow the tutorial and have just created a new project. Unfortunately when I open Eeschema the work area appears to be flipped vertically, including all text. While the horizontal scrollbar works as expected, the vertical scrollbar seems to scroll in the wrong direction. If I click on the page settings button a window is displayed, showing the information box correctly in the bottom-right corner. Please find screenshot attached.

I’m unsure if this is a simple configuration issue, user error or bug. Any help would be much appreciated.

Regards
Lax

Application: KiCad
Version: (5.1.6)-1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.66.0 OpenSSL/1.1.1d (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.1.1) nghttp2/1.39.2
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.71.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.66.0
Compiler: GCC 9.2.0 with C++ ABI 1013

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

Are you using KiCad in a virtual machine?

1 Like

Thanks for the quick respons eelik. Yes, VirtualBox.

They do that sometimes. I don’t know or remember if there’s any trick which would help with the virtual machine, unless changing Preferences -> Fallback toolset in KiCad works.

3 Likes

You can also try to find help for VirtualBox, like https://forums.virtualbox.org/viewtopic.php?f=2&t=92944&sid=02385c9650431cdcf8abf2408c534f14&start=15.

2 Likes

Bingo! Selecting ‘Modern Toolset (Fallback)’ from the Preferences menu has resolved the issue. Thank you.

1 Like

Just disable 3D acceleration in your VM settings. I had probems with some other software beeing upside down.

4 Likes

Report this as a bug to VirtualBox

1 Like