Schematic vanished

Newbie - Kicad 4.0.7 on Mac - can’t open .bak files (is there supposed to be a .sch-bak file?) - I get “kicad error - expecting ‘=’ in line 1” - and all following lines. Are the saved schematic files supposed in the (project name).bak files? I don’t see a specific “saved sch” file. I am pretty much resigned to starting over. Can a schematic be resurrected from a pdf that was plotted from the vanished schematic in kicad? Thanks

KiCad V4 is over 3 years old, and much has improved since…
Somewhere this year KiCad V6 i expected.

First thing you should do is make a backup, to prevent escalation from further errors you make.
Even in KiCad V5 there is not much automation ink KiCad’s backup files. The normal method is to rename a backup file to a schematic file (if it should be a schematic) or a pcb file (if it should be a pcb), and then open it normally with KiCad.

I’m not aware of any automated method to extract a KiCad schematic from a .pdf file. Re-entering the schematic with just the .pdf as an example of the parts used, where they are and how to connect them is better then nothing though.

There are some (I think at least 2 different) projects that are made to extract pinout data from datasheets and make KiCad symbols from them. If you have complex hand made parts in your old schematic (>100 pins) then that may be worth looking into. But the schematic symbols are not saved in the schematic itself, so if you made such, then they are probably still in a schematic symbol library.

Thank you. It was a shock to be presented with a blank eeschema screen - with the title of the schematic that I lost - as if I was just starting it. I probably accidentally agreed to erasure - when prompted by some cryptic Kicad message. I may take this opportunity to upgrade to V5 - to replace the version I have on my computer. I may have corrupted it somehow - I don’t have the same confidence in it. I’m hoping the upgrade won’t compromise my ability to edit schematics made with the earlier version. I will take your advice and backup my work - not relying entirely on Kicad to do so. Obviously, I am experiencing a painful learning curve.

Maybe you read over it:

If you have any file in your project directory, with a “.bak” extension, then rename it to the corresponding schematic file and try to open it in Eeschema.

Thanks - I will try that

Have you tried it yet?
Did it work for you?


P.s:
Instead of reporting 5 hours after my post that you will try it, it’s better to just try it and then report back whether it worked flawlessly, or you encountered some problem that needs more tinkering.

When you switch to v5 then you might want to read up on these two topics:

You are right - I should have tried it right away. I renamed the only file with a .bak extension in the folder containing all the files pertinent to this project - to .sch - and opened it. Unfortunately, what appears again is the blank/starting eeschema screen. The folder contains a .pro file and - particularly frustrating - a saved.pro file. Both of those are about 1kb in size. What should I see if I open those files? None of the files in the folder is big enough to be a schematic - typically, 1kb or less. The only file big enough was the pdf file made months ago - before the schematic was extensively edited. I appreciate your assistance.

Thank you. I will review those topics before I switch.

Do you recommend uninstalling Kicad 4 before switching to V5? Thanks