Schematic symbol renumber doesn't hold value


I’m on build 6703 on Windows and have been having a problem with symbol renumbering.
I’ll annotate the schematic like usual, and sometimes I’ll want to change a few (e.g. PCB layout position).
In the past few builds, I’ve been having the problem of the changes not “sticking”.

I’ll go to generate a net list and then assign to components, and nothing will have changed. I then return to the schematic
to see that the part numbers have reverted back to their previous values. I’ve discovered that if I close the schematic editor and reopen after making those changes, prior to making a net list, those changes remain.

Has anyone else had this issue or created a bug report?


Afaik the order of doing things is like this:

  • drop component in EESchema
  • annotate parts (references)
  • if you need, assign footprints via cvpcb, save assignment
  • create netlist
  • go to PCBnew and reload netlist (if you changed references, you should use the timestamp option instead of refrence)

Which part doesn’t work?

Sorry if I wasn’t clear enough. I’ve discovered the actual process behind it and it’s absolutely consistent.
It pertains only to EESchema.

If I edit a symbol’s reference number inside of a hierarchical sheet, leave that sheet, and then come back, the reference number is reverted back to the original value.

I submitted a bug report here with a bit more info on setup:

1 Like

Just tried… not happening in BZR6608 ?!
entered the h-sheet, edited a ref value (SW201 > SW203), left h-sheet, entered again… still SW203

Just tried the 4.0.2 Production build; works just fine.
I don’t have any nightly builds older than what’s in the repository (build 6663), but the problem is present in that one as well.

Cool… so it happened between 6608 and 6663.
Mention that on the bugtracker… devs will have a solution faster that way as they can pinpoint the pull that caused this easier :wink:

PS: you’re running default/legacy or opengl canvas?
Me = legacy

Mentioned. Thanks for trying it out on your build.

I do a bit of both: mostly legacy for part positioning and coarse routing, less frequently openGL for finer routing and push / shove.

The fix for this issue was committed in r6708. :smiley: