Schematic symbol connected but cant route in pcb

so I’m new to KiCad and have tried to google the issue but can not come up with a fix

I’m trying to connect a Connector_Samtec:Samtec_LSHM-150-xx.x-x-DV-N_2x50_P0.50mm_Vertical to my project but the pins are not being assigned to the footprint. all the pins have a global label but still not being assigned. I have tried aligning schematic to grid and changing the grid size in the pcb with no luck please help

I’m using kicad 7.0.10

Your symbol pin numbers and footprint pad numbers don’t match up.

is there a way to fix that? their both from the same item in the footprint library.

Probably easiest to use a different variant of the symbol, like the odd-even variant.

Tip: if you change the symbol, use the Change Symbol action rather than a delete and add, so that you can avoid having to relink the wires.

… and doublecheck with the data sheet of the connector if it turns out the way you intended :wink:

the only way I managed to find a way to fix it was manually assigning the pin numbers to the foot print

That’s another way but not so good because Samtec probably chose the numbers 1-50 for the connector pads. There is definitely a 2 row 50 pin connector symbol with numbers from 1-50 rather than 1a to 25b; I had a look earlier.

Why don’t you just download the Symbol & Footprints direct from Samtec ?