Schematic Library load issue - help appreciated

Hi all,

I have just re-installed my win7 Pro 64 bits on my computer and in that context have also re-installed KiCad (5.1.6). However, when I startup schematic (new schematic file) this happens:

  • It looks as if the symbol libraries load but when attempting to place a symbol the only available symbol libraries are “power” and “pspice” (pspice is empty). Nothing else.

This is in contrast with pcbnew footprints which load as they should.

Additionally, I cannot make schematic accept the folder where I have placed my own custom schematic symbols … The folder for these symbols is “opened” (i.e. one step deeper into the file structure) so that I have to add every symbol library individually. It has not been so previously but I can’t find a way to change it … ??

I would much appreciate if one of you happen to know what could be amiss here …

Cheers & thanks,


Because you have re-installed you may want to start from scratch. See Where are the configuration files (settings, library tables)?

There are two tools to add symbols in kicad. One is the generic add symbols tool and one is the add power symbol tool. My guess is you selected the second one which only shows libraries that contain at least one symbol marked as “this is a power symbol”.

The normal add symbol tool is the button right above the add power symbol tool (both in the right toolbar). Or you can use the “place” menu entry and of course the hotkey (i sadly do not remember the hotkey from the top of my head but it is listed in the “place” menu)

If i am correct then i assume you are quite new to KiCad (and possibly PCB design as a whole) in which case this tutorial could be of use: Tutorial: Introduction to PCB design with KiCad version 5.1 (Getting Started) (The section “Add Symbols” of the first schematic tutorial handles in detail how to add a symbol to the schematic)

Hi both - & many thanks for your feedbacks!

As it is the first issue - only having power & pspice symbols - was due to what you suggested Rene… I did hit the hot key “p” and it obviously would open up power symbols. In my previous installation of KiCAD I had changed the hotkeys to reflect the keys I use in e.g. LTSpice but had forgotten to do this again in KiCAD … my apology for this :roll_eyes:

Regarding your question whether I am new to KiCAD and PCB design I can say that I am somewhat new to KiCAD (and have had a long vacation = my mind memory needs to be refreshed) but I am actually quite experienced in PCB design not least when it comes to audio related PCBs. However, I have previously been using Diptrace and although at this point in time I consider KiCAD to be at least as “accessible” as Diptrace there are still some differences that I occasionally “stumble on”. This sometimes happens because KiCAD - to the way my intuition works - is not always as straightforward as I have found diptrace to be.

In any case the virtually empty library list when placing symbols is now solved - thanks!

Regarding my second library “challenge” - not being able to open my own library (called JESPER and containing about 20 individual .lib files) - I can see that in preferences->configure paths the KICAD_SYMBOL_USER_DIR points to the exact JESPER folder location on my drive. Yet, when - now correctly :upside_down_face: - I try to place a symbol this JESPER folder is not included in the library list. I get an error message saying that the JESPER.lib does not exist … And I reckon it does not as “JESPER” is not a .lib file but a folder.

Also, when I try to either add a library line ("+") called JESPER in preferences->manage libraries->global libraries and select the library path to be the same as the KICAD_SYMBOL_USER_DIR I cannot select the folder as such but can only select the individual schematic symbols meaning that I am adding all of these files to the library “root”.

I know it should not be so - in my previous installation JESPER was a folder like e.g. the 74xx folder containing these 20 individual symbol files - but I just cannot sort out how I set it up the last time … Might you have a suggestion as to what I am doing wrongly? I have included a screendump of what the symbol libraries (in the project manager & inside eeschema) look like.

I assume it has to do with KiCAD not accepting the folder “JESPER” as a library entity - only the individual schematic symbol library files have a .lib name - but it worked the last time. So I am just wondering what I do differently here …

Again I would appreciate your help in this …

Cheers & thanks,


Hi again … If somebody knows what could be amiss here since I can’t connect with my own library files I really would appreciate your help … I cannot figure out what it could be …



You might want to read Library management in KiCad version 5

TlDr of you main misunderstanding going from your previous reply: While footprint files are one footprint per file with the library being a directory, symbol libs are one file per library (so one “.lib” file contains many symbols).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.