Schematic editor symbols in the void - (living off grid)

Im not even sure how this happened, but… currently schematic is completely bricked.

First i was connecting everything normally, 100+ components.
Probably somehow changed the grid (maybe accidentally N) , so i first tried fixing by pressing N and trying, but none of the settings make it fixed.
So i started playing with grid sizes from drop down, also none work.
Basically my schematic is somewhere in between grids in the void, and wherever a move a component, it goes onto the NEW grid which is currently set, and then 2 are in parallel realities and unable to connect in any way.

How to quantize all to current grid, whatever that grid is? I tried just selecting all components and moving, so they would all snap to new grid. Obviously doesnt work cause they move in unison, so they’ll still be relative to each other. There is no way to snap all to current grid button?

How to find what the old grid was? It was the default one, but 0.64, 0.256, 1.27, nothing works so i dont know?

Currently I cant connect anything which killed the project dead in the tracks, kind of a silly way to go isnt it? One second i was editing, the other i was wondering why connecting stuff doesnt work anymore…
Please dont tell me that in Kicad 6, the best existing solution is to manually move every component by 1 space so they snap, and then reconnecting everything, or manually edit .sch im notepad, or whatever… :frowning:

Select your elements, Right-click and choose “Align Elements to Grid”

1 Like

Hello Seth,
Thank you! That is exactly the quantization feature i hoped for.
It disconnects all items since they’re now moved on grid, but i guess its a small price to pay :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.