Schematic Editor Snap to Grid

Hi All,

Having recently moved from Kicad 5 to 6, I’m mostly liking the new features and hetting used to the changed hotkeys - one thing I can’t figure out though:

I think Kicad 5 had some sort of snap to grid for symbols - like they could only be placed every 25mil or something. I seem to be missing this feature on Kicad 6, and it makes layout and spacing so much more difficult. Is there a way to turn this back on?

Many thanks,

normally grid-snapping in schematic-editor is always enabled.
The only exception is the use of the CTRL-key. This is the “disable grid-snapping”-modifier key. If these key is pressed during moving/placing a symbol/wire the grid-snapping is disabled momentary.

Are you 100% sure you have the grid set to some coarse value (0.05"/0.1")?

edit: additional question: which version exactly? (background: v6.0.3 was only available for few days and had some serious problems - don’t use)

Hi, thanks for your comment. I am using 6.0.4.

I have Grid thickness set to 1.5px, andI have played about with min grid spacing, both at 25 and 50px. Neither helps though.
This is through the ‘Preferences’ menu within Schematic editor.

Interestingly I do notice a difference when holding the ctrl key - it does no snapping at all.
It seems to currently be snapping to every 5 px, rather than 25px.

Thanks again,

Preferences–>setting (min grid spacing 25px/50px) is only visually and not the really grid.

The really grid-value is set with RMB-click–>context-menu–>Grid–> select grid value. Set to 0,1" (or 0.05"). This grid-value-setting is also displayed at bottom right of status-bar.
Be sure to set the grid-unit (inch, mil, mm) at the left iconbar (I recommend set to inch - and than forget and don’t change anymore).

Another possibility: RMB-click on the grid-icon in the left toolbar. This gives access to the grid-settings-dialog. This allows also to define the two “Alternative grid sizes” usually assigned to hotkey ALT+1/ALT+2.

1 Like

Haha, well don’t I feel like an idiot. It’s easy when you know.

All sorted, thank you very much for your quick replies!

Alignment to some coarse grid is pretty important for KiCad schematics.
On a “lower level”, it’s not the grid itself that matters, but end points of wires must align with attachment points of the pins from the schematic symbols for connections to be recognized, and this would be very cumbersome to do without a coarse grid.

You should never place schematic symbols, labels or wires off-grid.
This function by holding the control key is only meant for non-elecrtical things such as texts and graphic lines.

Open wire ends are indicated with small sqares, and open pins are indicated with a small round circle.
In the screenshot below R1 is connected, while R2 is not connected.
(It’s pretty clear when zoomed in this far).

Sometimes someone messes a schematic up pretty badly, most often by beginners disabling the grid, or setting it to a very fine size.
If this has happened you can select a group of parts and then select Align elements to Grid

In this example this resulted in a small move of R2** which “fixed” the open connections.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.