Schematic Editor drawing graphic lines instead of wires

From the image below, when I go to click the little red square, of which you typically click to automatically begin a line, for some reason starts as a graphic line. Doesn’t really matter what I do…


I even went and manually picked “wire” from my tool bar and drew a wire manually, then just to check - I hit esc, to end the wire tool, then I go over the green box left by the wire shown below:

And for some reason when I hover over the green box, it gives the cursor symbol of a graphic line again?!?.. so frustrating - did I click a setting unknowingly or something? Btw you can’t see my cursor cause of the windows screenshot feature but…

Please post your Kicad version.

Help > About Kicad > top RH corner “copy version info”
Paste to forum.

1 Like

Under Schematic Setup > Project > Net Classes, you can define the line style for each net class. Has the line style beeh changed from solid style? Maybe this was in the saved project settings and not explicitly changed by you.

Yes, but it will continue with that style, not be overridden by a green wire as example 2???

No :eye::deer:. Just a suggestion.

Ahhh,
welcome to the club! :slightly_smiling_face:

I’m hoping it is an old version with a problem that has since been rectified. Hence, the “please post version”.

As a more thorough test to what you’re actually drawing (a graphics line or a “wire” with fancy attributes) put two connectors on your schematic and draw some lines between them and: Schematic Editor / Tools / Update PCB From Schematic [F8]. When you see ratsnest lines the connections are recognized.

But both your cursor descriptions and the (default) line types suggest it’s some weird KiCad bug. Is this project specific? Does it also happen in other projects?

There is a problem in 6.99

ksnip_20221124-003059

Changing a graphic line from solid to dashed then to dotted, afterwhich changing the color from blue to magenta resulted in this mess.
It doesn’t have anything, that I can see, to do with the OPs problem.

I’ll investigate further tomorrow (after updating 6.99) and report the bug if no one else has. Too late tonight to continue for me, it’s bed time.

Application: KiCad Schematic Editor

Version: 6.99.0-unknown-95b8fe26b4~160~ubuntu20.04.1, release build

Libraries:
wxWidgets 3.0.4
FreeType 2.10.1
HarfBuzz 2.6.4
FontConfig 2.13.1
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-132-generic x86_64, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: Nov 18 2022 03:48:58
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.68.0
ngspice: 38
Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:
KICAD_SPICE=ON

@ch992319 : we need the kicad-version. There was abug with the described behaviour (autostart graphic line instead of autostart wire), but if I remember correctly it was fixed some time ago.

@jmk : looks weird, but I could not reproduce this image.

1 Like

@mf_ibfeew

It’s a Nov.18 build, things may have changed.

I am still up.
Seems not to fault unless it is attached to a global label and only if you try to modify a “default style” graphic line.
Global label can be either input or output so far as I have tested.
Fault doesn’t occur with an unattached graphic line.

Also seems to only occur if the graphic line is at a not 90 degree angle.

See ddd. www does not fault.

I think this is going to require some research into where the problem occurs. :slightly_frowning_face:
I’ll update and spend some time on this tomorrow unless someone replies here or files a bug or the problem clears with an update.

Things have indeed changed. The problem is no longer with the current 6.99.