Schematic editor changes the placement of symbol fields

Hello!

Merry christmas to everybody!
As stated in the title, I have defined a symbol as follows in the schematic editor.
Editor

Then when actually using it in the schematic, it looks like this:

Schematic

The reference and label have moved. Is there a way to keep my settings right?
The funny thing is that at first when creating a symbol, the reference and label are at the center and overlapped (1), then they have to be moved.

(1) By the way, it would be very nice if they weren’t overlapped at first. It would allow to select them at once.

Another problem is that my settings are ignored. In the symbol editor, I always set halign and valign to center, but once in the schematic, it is reset to some kind of default, halign = left, valign = center.

Settings

Is there a setting somewhaer allowing me to use exactly what I have setup and not system defaults?

Thanks,

Pascal

Is it possible that you have 2 symbols with the same name?

After creating this new symbol, did you save it? What does it look like when you reopen it with the symbol editor?

Fields are auto placed with kicads default settings. This can be turned off somewhere in the preferences dialog. (Autoplace fields is required for rotating and mirroring of symbols)

1 Like

Hello Rene!
Thanks for your help. In case somebody else has the same problem, here is where the
“somewhere” is:
In EESchema:
Go to Preferences -> Preferences, and open EESchema. You will get this, where you can uncheck
the box labeled “Automatically place symbol fields”.

It does the job!

Thanks,

Pascal

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.