Schematic DRC shows no connection but it's there?

So tried using DRC within the schematics too and been presented with a great list of errors.

Majority of these appear as ‘no connection’ although it is present.

See image below.

If I delete the connection (a.k.a green line) and reconnect the error goes away.

Any suggestions?

If a pin is connected to a label, but the label is only used once, then the pin is still unconnected.

The hint is in the 2nd ERC error:
Global label not connected to any other global label.

If you want to keep the global label for clarity, but have no place for the wire to go to, then add another global label with a no connect flag, like so:

1 Like

Maybe I took bad example, I get around 30 errors.

Another example would be this:

And error says: ‘Pin connected to other pins, but not driven by any pin’.

Pin connected to other pins, but not driven by any pin is another sort of ERC error.

For these you have to use the PWR_FLAG symbol, or it can be generated by a net that only has inputs, and no output to drive them, just like the text says.

Can you expand on PWR_FLAG please?

Within same circuit I have following:

But even if I check others, I have errors such as:

Where the left connection is going to IC and is connected, but error states ‘Pin connected to other pins, but not driven by any pin’

There is same label that is connected to another IC but still get error

1 Like

Yes, it’s still unconnected.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.