Schematic "created in more recent version" won't open. Created in this version!

I closed my project and went to open it and now I can’t open the schematic. It won’t open and give the error about it being created in a more recent version of Kicad. It was created in 7.0.2 released version and that is what I have. It has been working the last 2 days. I just copied files into another folder and sent them. This is a github repository, but the really strange thing is I have tried 7 or more different backups going back since yesterday and NONE of them open! I don’t think it can really be the schematic file, there must be something else going on.

Can you post the first couple of lines of a schematic file?

Is it possible that somehow you started an older version of KiCad like v6 by accident?

No, I even re-installed Kicad 7.0.2. I tried changing the date of the file and if I moved it far back enough in time, I could open the file, but it didn’t understand pages, so I could only see the first page. Of course all of my important stuff is on the second page. Where is it doing this check? It is like the program itself doesn’t know it is a 2023 version:

kicad_sch (version 20230221) (generator eeschema)

(uuid d9bffcd6-0c76-43dc-a547-0625663e12a4)

(paper “A4”)

(symbol “ESP32-S3-WROOM-1U:ESP32-S3-WROOM-1U” (pin_names (offset 1.016)) (in_bom yes) (on_board yes)
(property “Reference” “U” (at -10.16 31.369 0)
(effects (font (size 1.27 1.27)) (justify left bottom))

Has to be a bug because even installing the 7.0.2 version is not working. Not sure what date it is checking and were it is getting it.

If there’s a schematic you don’t mind sharing you could post it here and other forum users could try to open it.

enhanced-mega-shield.kicad_sch (35.6 KB)

Here it is. I have several days of backups and none of them load, though they did earlier today. I can change the file date and get it to open, but it won’t read the second page. It says it was created with an “Earlier” version then! So it things it was a more recent version, until it opens it and then shows the bar at the top that says it is an older version and will be converted when saved. I wonder if this has anything to do with parts and footprints that I had to add to Kicad to for page 2 of this schematic

Hmm, I’m running 7.0.1 and I get the same message as you.

However one of my projects done in 7.0.1 has as the first line:

(kicad_sch (version 20230121) (generator eeschema)

So I don’t know, somebody else will have to diagnose.

Here is the entire project. There are 2 .sch files since it has 2 pages. All the data seems to be there, but even messing with the dates inside the files, it will only load the first page. (253.6 KB)

I tried it with 7.02 and 7.99, Win 11.

7.99: works ok.
7.0.2: schematic exhibits the said error. Anyways, the board opens alright

Just my 2 pence.

That is interesting. I have 7.99 last year but uninstalled it when 7 was released. I can’t figure out where the error lies. I wish I had a version that was working so I could compare the two files. What dates is it checking? It seems that it would be an issue with the program itself since you can clearly see the dates in the files and whatever it is comparing against in the program is not correctly doing the math.

That was likely 6.99. 7.99 is what will be V8.

Looks like all of the schematics were created with 7.99

enhanced-mega-shield.kicad_sch:(kicad_sch (version 20230221) (generator eeschema)
through_holes.kicad_sch:(kicad_sch (version 20230221) (generator eeschema)
untitled.kicad_sch:(kicad_sch (version 20230221) (generator eeschema)

PCB Was done with an earlier version:

enhanced-mega-shield.kicad_pcb:(kicad_pcb (version 20221018) (generator pcbnew)

Guessing you created the sch+pcb in 6.x and then installed 7.99 and edited the sch file.

I’ve got 7.0.2 installed and a new sch file gives:

version 20230121

As a hack I edited the sch files and changed to version to 20230121

This seems to fix it in that I can open the file, but not sure if it’s the right way to fix it. Maybe something else breaks.

This is the strangest thing unless I have some corruption or the download from the last 2 days for windows has an issue with numbering and thinks it is 7.99. I’ve learned a bit about how the files work now. I’m sticking with the release version now since I have to share files with others.

I think somehow you installed 7.99 and/or ran an eeschema executable from 7.99. It’s not what Windows thinks but the version number in the application that it writes to the schematics that matters.

I just saw the exact same thing happen. I downloaded and installed 7.0.2 about 2 weeks ago, and a coworker downloaded and installed KiCad about 5 days ago (both on Windows). I can’t open schematics they made and get the same error. I also noticed that they had a footprint in their library that I didn’t have. I wonder if a preview version somehow got uploaded somewhere but labeled as 7.0.2.

Could you get the version info from both systems?
Help → About KiCad → Copy version info

Sorry for the noise, it was user error. Both 6.0 and 7.0 were installed on the same computer, and “double clicking” on the .sch opened 6.0 (but then closed it immediately so we couldn’t tell it was 6.0). When 7.0 was installed, file associations didn’t update. Uninstalling 6.0 fixed it.