Schema 5.99 File is already open error - lock file problem

I’m getting a “File is already open” error while trying to open a file done in Kicad 5.99
After it posts the error it shows me a blank schematic sheet instead of my file.
Anyone have any suggestions?

The file is definitely not open somewhere. Is there an open flag embedded in the file itself somewhere?

Application: KiCad Schematic Editor

Version: (5.99.0-11177-g6c67dfa032), release build

wxWidgets 3.1.5
libcurl/7.54.0 LibreSSL/2.6.5 zlib/1.2.11 nghttp2/1.24.1

Platform: macOS Mojave Version 10.14.6 (Build 18G87), 64 bit, Little endian, wxMac

Build Info:
Date: Jun 28 2021 23:57:20
wxWidgets: 3.1.5 (wchar_t,STL containers)
Boost: 1.76.0
OCC: 7.5.1
Curl: 7.54.0
ngspice: 31
Compiler: Clang 10.0.1 with C++ ABI 1002

Build settings:

Things I’ve tried - I downloaded latest version of nightlies 5.99 - same error
Checked permissions on the file
Set permissions wide open
Some files have an @ sign at the end indicating metadata
I zapped this on the schematic file but no joy

Is there a json file where Kicad saves its last loaded file?
It is likely that Kicad crashed as I had a laptop crash or two from low battery.

I have found the file reference in the Preferences>KIcad>5.99>eeschema.json
Nothing out of order - I edited out some duplicate references with no joy.
Zapped all the file references with no joy.

Anyone know whether I can just delete all those json files - or is that a recipe for disaster?
Or at least a lot of work re-setting things up.

I also think I should have posted this in the Software category - maybe an admin can move it there? Thanks and sorry for not reading details about where to post (done, Joan)

It just resets everything so that when next time you start, KiCad starts from scratch. I would keep the sym-lib-table and fp-lib-table files so that the library setup is kept, otherwise it’s safe and easy to delete everything.


It turned out to be a lock file found on MacOS at ~/Library/Caches/kicad
I just cleaned out the eeschema lock files and things worked again.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.