Sch file NOT recognized by EESchema

Schematic complete and available in .pro together with .net and yet to be started .brd. Now .sch has disappeared from .pro!

Please rephrase that question/statement if you need help as no one understands what you’re trying to do nor what you did.

Sorry for my cryptic first attempt!
I completed a schematic and created footprints for a subsequent pcb. In my .pro project there is a .brd, .net and .sch file. I normally open my schematic by double-clicking on the .sch file. When I recently
opened my project the .sch file was not present. So I selected the EESchema icon (leftmost of
5 icons). This opened a blank schematic sheet with the following- .sch NOT recognized by EESchema.
I then searched for my schematic using Vista search. Unfortunately it was not found.

I am using build: (2011-04-29 BZR-2986)-stable wxWidgets 2.8.12 Unicode and boost::polygon on Windows.

I consider the potential loss of my three sheet schematic as problematic and has resulted in me losing confidence in my ability to use kicad. I assume that my system is not set up correctly to handle projects and
that my schematic shall reappear when I sort this out.
If I need to provide any other details then please contact me.
Thanks Kevin

Sent from Samsung Mobile

If it’s not in the windows bin (the .sch file) then it probably has been overwritten somehow/somewhen.
Is there a .bak file in that project folder?
That should contain a backup of the .sch file… but I have no idea if you version of KiCAD did that.
Can you post a screenshot of the folder with the files or give us a list what’s all in there (with file sizes).

Also the KiCAD version you’re using is pretty outdated, get a more recent version if you want to profit from more stability.

I tried to reply to your email with an attached screenshot. This failed as I am a new forum member. I shall try again tomorrow.

Sent from Samsung Mobile

I tried to send you the screenshot as part of the body of my email. Again the email delivery failed. Please advise how I can send a screenshot as a new forum user

Sent from Samsung Mobile

When you hit reply to this post, there is a menu at the top of the message input area… one of them is an upload button for files which also takes images.

Subject: [ Forums] Email issue – Posting error
Date: 14 October 2015 16:27

We’re sorry, but your email message to [“”] (titled Fw:) didn’t work.


Sorry, new users can’t put attachments in posts.

If you can correct the problem, please try again.

Same issue when posting this reply.

That’s odd… I remember there being some kind of limit for me the first couple of days in regards to number of posts and/or attachments… but you’ve made at least 5 posts by now.
Can you have a pc running with the KiCAD info website open for a while? This should keep you logged in and increase your rep faster…

For the time being I sent you a msg with my mail addr… send me the pic there.

That doesn’t look good… you got all your projects in one folder, that will cause trouble.
I did that too for my very first project and it ended in tears :wink:

So, one folder per project.

[quote=“kellykev, post:8, topic:1489”]
All my projects are in one folder as determined by kicad and not by me. Please advise how I can correct this. See attached screenshot2 attempt to move project. Attached screenshot3 shows my schematic when you it the COMPATIBILITY FILES icon. Please advise how I can access it.[/quote]

I don’t know about your setup, but mine looks like this:

C: [Windows + Programs]
D: [Windows Swap File]
E: [Data]

C & D are on a SSD, E is a normal mechanical HDD

KiCAD is installed on C:\Program Files\KiCad\

My KiCAD projects, library, footprints and 3D models reside here E:\Data_KiCAD\ and it looks like this:

Your problem now is, that the folder where your projects are has some access settings that prevent you from moving stuff (maybe you can just copy it?)… you have to change file/folder access rights.
Then I’d suggest you move your projects into a folder that you have easy access too… my setup above allows me (I have it like that for all my files) to make a backup of E and that’s it. No worries if I missed any data files somewhere else in the system, nor do I rely on the OS capabilities to do that.

Same with the libraries and footprints…

Once you have that folder, if you create a new project, create a folder for it first and then create the project INSIDE that folder. No more mixing of projects.

Good luck.

PS: when you open a project, KiCAD always drops you off in the installation folder… I made me a shortcut in there, that points to above mentioned project folder… so I just have to click on that and I’m where my projects are. KiCAD doesn’t seem to accept changes to this behavior in the settings file for this… at least mine always changes the drop-off folder back to the install folder.