Save button in cvpcb is creating .cmp file but not updating the netlist

Hi Folks,

I’m using stable build BZR-4022 on Windows 7.
I export my netlist from eeschema then do the associations in cvpcb.
I press the “Save the component/ footprint link file” button and it creates a .cmp but does not update the netlist.
I don’t see any other save button/ preference that would cause the netlist to be updated too.
What am I doing wrong?!

Thanks for your help.

My issue may due to inaccurate information in the “Getting Started in KiCad” documentation delivered with the BZR-4022 download. Step 52 says:
“You are done. You can now update your netlist file with all the associated footprints. Click on File→Save
As. The default name ‘’ is fine, click save. Otherwise you can use the icon . Your netlist file
has now been updated with all the footprints.”

The software doesn’t give an option to save a .net file. It gives an option to save a .cmp file so I guess this version of the software no longer updates the .net file.
Anyways, I just use the “Import the Footprint selection from cvpcb” after creating the .cmp and all good now :smile:

I had a similar issue, but thought perhaps by design eschema is the only module that can update the netlist whereas the .cmp file appears to be for information flowing back from pcbnew to eschema. And it only contains a limited amount of detail at that.

For example I changed a pin header footprint value “AVR-ISP-6” to just “ISP”, but after exporting .cmp, importing that into eschema, exporting the netlist (which I did because I had added some forgotten decoupling capacitors in the schematic) then re-loading the netlist in pcbnew the value was back to AVR-ISP-6. The extra capacitors were included though.

If you make changes at both the board and schematic, is there more you need do to share those changes between pcbnew and eschema? In Eagle back-annotation included far more info than just changed footprint names so I expect I’m misunderstanding the workflow required to do the same in KiCad.