"Save As" from within Eeschema?

Thanks a lot, devbisme.

Showing two branches. “master” (black) and “testing” (red).

TL;DR The “save as” menu entries only appear when you start eeschema and pcbnew in the so called “standalone” mode. This means invoking the eeschema.exe and pcbnew.exe directly, and not starting those from the project context, as is done when you open your project in kicad.exe and click the files or icons to start the respective app.

Thanks a lot, nickoe. I will have to try that…

Glad to see the “save as” issue clarified. I am waiting for the new stable release before I try it. In the meantime, for anyone needing version control for anything, software, pcbs, manuscripts, etc. a legal free book on subversion starting at square 1 is available. Version Control with Subversion

Well, thanks to all those who made sincere efforts to help. I tried the “save as” using eeschema in standalone mode. But that introduced at least one problem with one of my schematic symbols. Now I have spent a little while trying to figure out git. I have watched a couple of videos and tried both gitbash and the git GUI. BTW even the help from the git GUI does not offer any “how to” on the git GUI. This seems like jumping into the middle of the ocean after nearly drowning in the deep end of the pool. Even if I do not drown it is too much of a detour. I think I will simply save different versions in zip files so I can control what I am doing…

1 Like

Hey, Bob, thanks for at least giving git a try!

Thanks, devbisme

I guess my priority is to learn KiCad first. If I need git at a later point I am open to trying again…

I hope that the zip files work but I cannot imagine why they would not.

Best regards,


Hey Bob,

zip files work!
currently i also do ‘versioning’ with zip files.
so if i send a board to the manufacture i first create a zip. so i know what i send out…

in the future i will try to use git for the process - it makes sense -
but i am familiar with it(from my software development…)
hopefully i will find the time to write some ‘tutorail’ or ‘get started with Kicad and Git’
if i do i will let you know!

sunny greetings

Thank you, Stefan

Yes just yesterday I was experimenting with grounding schemes; trying two different grounds instead of one. I was asking about this in another discussion thread. Anyway I had started off with a single ground and then tried to use two different grounds, saving my versions in zip files. The two grounds did not work well so I have gone back to my zipped (previous version) single ground scheme. All seems to be working OK!

Best regards,


Thanks, Andy

Understood. Right now I am in the midst of two lines of study one of which is KiCad. The other is something else with which I am stuck at the moment.

It seems that if I want to use GIT I have to learn how to use it with all of these command prompts and I see myself just getting stuck in that detour. So two lines of study on which I am stuck. Really I see myself progressing with KiCad in other regards and I really want to learn it.

I understand and appreciate that git may be useful (or even great) and I have no objections to learning it at a later point after I have learned how to do what I want using KiCad. I used to criticize Microsoft for the lameness of their help files, but I find little if any software by anyone with help that is well written for the person who does not know.

For example one video on git shows operation with command prompt. But all of these command prompt lines show a “$” at the beginning. Why is that there and what does it do? Why do you type it? I have never seen that when using the command prompt. I do not think that it was clearly mentioned that if you launch gitbash from Windows, that gives you the command prompt (of sorts) and places that $ at the start of each line. I still do not know what the $ is for.

Imagine a 17 year old whose mentor wants to teach him heel and toe downshifting of a 2008 car with a 5 speed manual transmission. Or maybe to first learn Swahili because that is the language of the mentor’s favorite driving instructor. But the 17 year old wants to first just get his driver’s license on a car with an automatic, maybe with an English speaking driving instructor.

BTW I got my drivers license on a '65 Dodge with a 3 speed manual on the steering column. My present car has a 6 speed manual but I never learned heel-and-toe downshifting. :frowning:


Have you tried “File >> Save current sheet as” ? I am not experienced user, but this could probably solve your problem.

Hi, Andy P

Thanks a lot for explaining more about Github. I was concerned that even if I learned to use git it might not be obvious how to apply it to KiCad.


Thanks, Newone

If you look up in the discussion string, you can see that that was recommended by one contributor. Actually I did not see any option for saving the complete schematic file; only the current sheet as.

  1. You have to use Eeschema in standalone mode; not launched from project manager in order to access the “save as” command.

  2. I tried it and encountered issues with at least one of my library components. I am using my own library components, and I think that changing the name of the schematic file only may be problematic. I seem to be making the libraries work somehow but I do not fully understand it…

Within project-launched KiCad I see only “Save current sheet” without the “as”.

Bob Z


If you want to keep your version control local on your own system, try Subversion. See this post.