SAMACSYS downloaded sch lib can not see pin names

SAMACSYS downloaded sch lib can not see pin names

anybody has the same problem?
I already tried a few ways to solve it ,but no luck.

Where are you looking ? in the Schematic editor or the Symbol editor ?

Learn to use the Symbol Editor. Websites, like Samacsys, SnapEDA, PCBlibraries and such can save you some time, but often the symbols and footprints you get from such sites are not “ideal”. If you know how to use the symbol editor (it’s not very difficult) you can fix issues with library symbols yourself. Also, every now and then you may find that none of those sites have what you need. In that case you can make the symbol (or footprint) yourself. Both the symbol and footprint editors in KiCad are quite good, and easy to use. They are very similar to the schematic and PCB editors. They do of course have a bit different functionality so it does take some time and effort.

in the schematic editor

the symbol editor does not have this problem

I’m pretty sure the default action for symbols in the Schematic editor is to not show Pin names or Numbers . . .

image

you can turn them on using the symbol properties.

thank you for your inputs.

I already changed the properties a little bit to fit design requirement in the symbol editor.

I can solve the problem by download the library files one by one, and then import to local libs.

I just do not know why the other way can not work by using KICAD libraries plugin

no.

I already checked this.

OK, can you give a link to the particular SamacSys library ? or a name for it.

thank you guys for all your inputs.
And sorry for I did not clearly descript my problem.
It is probably that the reason is the KiCAD library plugin or the way I use it.

the problem solved by a indirect way.

thank you again.

1 Like

Please explain. Other may come along with the same problem

use the components search engine to download the lib, then import to kicad project.