Routing in PCBnew

In at least v6 and v7 and maybe earlier versions, there is some “feature” that, during routing, that seems to take control, usually because I am sloppy moving the mouse, and causes the route to jump around and do strange things. Is there any way to turn this off?


1 Like

Maybe Route > Interactive Router settings, do you have Jump over obstacles ticked ?


Now I’m a bit confused.
You joined this forum in February 2019, about 4 1/2 years ago, and you haven’t found the Interactive router settings? Maybe you use KiCad only occasionally…

I recommend to experiment with the other settings for the Interactive router to adjust it to your liking. Different task may also work best with different settings. Also, don’t be too quick with turning features off. Some of them take some time to get used to, but can increase productivity and you may learn to appreciate them.

1 Like

All the time I can’t get used to jumping the cursor to pad center even I have zoom so big that it means jump half the screen. I think that I can’t switch it temporary off while not switching off jumping to grid at the same time. I don’t want to switch it off permanently as last track segment should finish at pad center.
I have written bug report 4…5 years ago suggesting to limit snapping to move the cursor not more than specified screen distance. If it were done than if you want something different than interactive router wants you could get it by just zooming in.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.