Restrict 3d view board to edge.cuts layer


#1

Not sure how to work the topic or if this is correct section, so let me know if there are words I should have googled to find this.

I use right angle connectors that have to be on the edge of the board or the plug won’t fit. I have a line on the footprints that must be off the board for it to be possible to connect the plug to the connector.

However, if I use 3d view, even though I’ve created a board outline on edge.cuts layer it extends the pcb to these lines. is it possible to allow components or parts of components to be off the pcb on the 3d viewer?


#2

Something doesn’t sound right here. I have components that I haven’t placed on the board show up ‘floating in air’. I just did a test and moved a part off the board and got the expected results.

Go to the PCB layout and turn off everything but edge cuts to make sure your edges are well defined and CLOSED. Without edge cuts I believe the software adds just enough board to display.


#3

Apologies, my board outline was drawn on eco2.user layer. Maybe I start using eco1.user for dimensions to avoid this problem.


#4

Complex software, complex learning curve. I’m just glad it was an easy fix for you.