Restore old schematic after pcb netlist reading overwrote schematic parts with '?'

Hi there,

I am working with KiCad 4.0.0. rc1 and Eagle 7.4.0.
I worked on a schematic that I imported from Eagle via an ulp macro into KiCad. Because mainly all parts originated from Eagle/spice library it worked 80% OK. I edited the schematic in KiCad and added to all parts footprints from the library. Then I used CvPcb for associate footprints to all parts and saved it. Then I created a netlist and saved it as well. I checked the feature “annotation only to this eeschema”.
I saved the Eeschema and opend pcbnew. I read in the netlist and the problem started:
First I got the information, that some parts were not in the libraries. Second, all parts found, were all placed in the center of the board, instead of being placed side by side.
When I opened the schematic again, all parts were gone, replaced by ‘??’.
Therefore some questions:
Is this a bug or missed I something?
Is there a way to recover my old schematic?
Is there a way to place the parts side by side automatically in the pcb?

Thanks for your help in advance.

Best regards


In pcbnew click on the button with the white IC that has got green pads and 4 arrows on it (in the top tool row).
Then right click somewhere in the drawing area, chose ‘Global spread and place’ and chose an option that fits your needs… if you already got parts laid out and get some more loaded take the option where it leaves the parts that are within a edge.cutout (ie on the board) alone… otherwise, happy re-layouting :smiling_imp:
Once done, switch off that IC button again (Mode footprint)

It can’t find the schematic symbols you have used in the schematic… are your library paths ok?
Can you load those missing symbols in the library editor/browser?
Did you delete the library/symbols in it?

As soon as it can access those libraries again the missing symbols will re-appear…

Hi Joan_Sparky,

thanks for the hint. I clicked on the named button for ‘Global spread and place’, but right click in the drawing area doesn’t give any option for placing, only for zooming and something like that.

Seems, that importing files from Eagle does not work well. Because, there are so many things that need to be fixed manually afterwards. It is somewhat time consuming rewriting my schematics completely from scratch again. Sigh.

Anyway, I keep on trying.



I checked the path configuration in the main application. They are all there.

But when I check Libraries in Eeschema, it looks like this:

(When I edited the schematic the first time I saved everything and everthing was there when I reopened it.)

download the libraries manually I’d say :wink:

Personally I don’t use them, I got my own and if I need a new symbol I just make it - less stress.

Seems to me that I missed something. Because, I opened another schematic which I edited completely in Eeschema and again all parts are lost and only those ‘??’ are shown.

How can I synchronize the above shown path menues regarding part libraries to make shure Eeschema keeps the parts in place?

I am using the KiCad project manager.