Replicate board layout from image (Reverse engineer comodore C64 board)

Well that might be because the socket footprint has the wrong 3d model assigned. (I checked a random socket footprint in the official lib and that one at least has the _socket suffix also in the 3d path. So i guess you have your socket footprint from some other place or i was lucky with the random footprint i checked.)

Remember that the official lib does not claim to be complete. We have what has been contributed. If something is missing it is not because we don’t want it but because nobody cared to contribute it in a way that we can accept it. (Contributions to the official library need to follow the kicad library convention. We prefer quality over quantity.)

i was looking in the DIP sockets folder that came with kicad

\Program Files\KiCad\share\kicad\modules\packages3d\Sockets_DIP.3dshapes

the one i looked at was DIP-40_600

There is more then one reason why we did not include these models in the new repo :wink:


i just use what came with kicad 4.0.7, sorry for being a noop :stuck_out_tongue:

found a lib that works fine and has ic’s in a socket or standalone

i was to quick and did not preview the footprints before i saved them so when i got a 3d view of the board some where offset.

i corrected that and did run cvpcb (without changing anything)… recreated the netlist in schematic… read the netlist in pcbnew… but the 3d view does not update

i’m surely doing something wrong, but i have no clue what

i just rechecked… if i go to pcbnew and edit with footprint editor but click 3d view without touching anything the 3d view is not correct… but still if i click 3d view in pcbnew it does not update the 3d view…

picked another footprint and regenerated the netlist and then reread it in pcbnew and then change back to the footprint and reread netlist again made it work

now is there a quick way to change color of a 3d shape? i can use the same shape for about half of things but if it was easy i wanted to change the color to get a closer match of the org components

moved on to edit some of the ports

they all require milling and that is the problem i have now… as the dummie i am i look for a milling layer when i edit the pcb footprint, and then i googled and the best things is to use the edge cut layer

but that is grayed out

a screen shot:

Yes sadly it is not possible to use the footprint editor to draw on the edge cuts layer. This issue is known but will sadly not be fixed until after the kicad 5 release (

Your only option is to draw on any layer and move the drawing to the edge cuts layer using a text editor. (I would suggest you use any layer that you do not use for anything else. This makes editing easier as you can then do a simple search/replace)

thanks for that… as i have made seperate footprints for almost everything it should not take long to edit the 3 parts needed

that worked and i’m down to 90 or so connections not done.

i have found out that like with everything commodore the schematic is not quite right so i will have to figure how to change it if needed to have it “sync” with the board. even thou the board i have in hand came from a repair place it was once working. it had a few cut tracks due to unskilled people working on it and all the holes plating had come loose, but good enough for a scanning and use as template. so in the end i trust the board more than the schematic.

i tried to make ground flood areas as that is used arround the edge of the board and under the video section.

i could draw the area fine but i tried to use keepout to stop the flood as there are some areas within the shape that is not to to be grounded. what is the correct way to do this?

i have 4 connections left

Q: are there a way i can get a drill file from sprint layout in to Kicad so i can verify i got all via’s ?

its just temp i need it so on the eco layers would be fine

what is ‘sprint layout’ ?
If you have jpg files only, those will not have XY co-ordinates needed for drill, but you may be able to extract vector info.

Google does find some interesting things under Image To Gerber Conversion eg

Gerber is vector based, so once you have that, you can start to match things up.
This post, suggests KiCad’s GerbView can export KiCad PCB files…

Sprint layout is a program that allows to have a picture as background template

I do have a real gerber drill file i want to turn in to a DXF so i can import that in kicad on the eco layers

i did try Gerbview but could not get it to work… will read teh last link and see if i get anywhere

i could import the drill file, now i just need to figure how to export it to one of the eco layers or any other layer that is not in use

that did go smooth, i had the option to save it as a board and was able to select a layer

but on the current board the append option is grayed out so i cant select it

can i convert a board to a footprint?

If you have opened pcbnew (the board editor) from a KiCad project it doesn’t let you append a board (an artificial limitation IMO). You can try to open pcbnew as a standalone program, open the actual board, then append the other board, save, open again as a project. Save a backup first!


backup is allready saved now i’m so close to done :smiley:

so what i did was use gerbview to open the drill file and then save it as a new board with the front adhesion layer

then i did as @eelik suggested and i was able to append the drill board to my working one

of course all the holes for the components covers the purple dots for the holes… BUT not the via and that was the most important thing, ie i want to check that i got all the via’s :smiley:

so i spend some hours to get the last few connections done and fine adjusted placements of via’s

for some reason the board has 2 ic’s on it but its not to be found on any schematic

i found what they are in a spare parts catalogue and i think i can manage to make the few connections in the schematic by looking at the board

but i have found something very frustrating… it’s the 74ls02 symbol that comes with kicad. it has the power pins hidden and i need them visible as a seperate unit. i managed to make them visible.

but dont want the symbol that shows up on unit a-d

i did google again and got no where.

a few screen captures:

if i remove the checkmark for common in unit A it stays in unit A but goes away in all the others.

My aim is to remove the symbol shape only in last unit (E)

last pic on imgur is showing my problem more clear. Unit A and E are as i want them, But the rest is missing the symbol chape