Renaming "Create Footprint Wizard" Footprints _before_ exporting into a library

Hello,

A quick question that’s been bugging me for ages.
When using Create Footprint (i.e. the footprint wizard), let’s say you create an 8-pin SOIC-like package.
I can’t see how to change the name from the default that the wizard offers (i.e. SOIC-8).
Nine times out of ten you want a different name to the default (for instance, you may wish to call it SOIC-8-OnSemi or whatever, if you’re fine-tuning it.
I know that the footprint can be renamed after clicking the “export footprint to editor” button, but is it possible to do it prior? To me it feels the name ought to be a configurable parameter, or be prompted after clicking the button.

The reason it is an issue, is that you may already have a footprint with the same name (e.g. SOIC-8). You can’t tell either, because while the footprint wizard is running, you can’t click on the Footprint Editor to double-check, because (at least on Microsoft Windows) the system won’t allow you to click that until you close the Wizard window.
For sure I could open up a file explorer box and check there, or abort the Footprint Wizard and then check, but it doesn’t solve the root of the problem, which is that there’s a good chance you already have a SOIC-8 or whatever in your library and you don’t want it overwritten by the Footprint Editor.
I have been caught out by this a lot : (
Am I accidentally missing something? Is there a way to set the footprint name before export? Or some other decent workaround? Many thanks!

Tip’s:

• I Always prefer to Copy a Kicad stock Footprint and Symbol, then paste it into my preferred folder. You can Right-Click and Rename it then.

Alternately, can Copy/Duplicate/Rename and Move it BUT, I prefer the above approach.

• When Creating a New Footprint/Symbol, 'First’ Select the desired folder to save it to, then Save (first selecting the destination Folder is what enables setting a New Name)

• Setup your Paths to point to your preferred folder
See my recent post Here…

Video may help

1 Like

Hi,
Please could you clarify what you mean by first select the folder and then save? If I do that (say creating a dummy footprint as in your video), how do I invoke the footprint wizard to apply to that dummy footprint name?

As you mentioned, it is possible to copy-paste footprints, or duplicate/rename. I do that frequently, since it is often easier to edit an existing footprint. However, there are also occasions when I really do wish to use the footprint wizard (especially since it’s not possible to change attributes of every pad in a footprint in one go, so I’d rather fire up the footprint wizard and redo it from scratch if (say) a SOIC-24 footprint requires 0.1mm narrower pads for all 24 pads, than a normal SOIC-24 footprint, etc.
I didn’t think the workflow I was doing was abnormal, so I’m surprised that the footprint wizard will silently overwrite footprints with the same name (and provide no opportunity for the user to change the name beforehand).

Hum… seems clear to me in video:

• Create New Footprint (doesn’t matter type so, I selected (Other’)
• Drew a Silk Rectange (you would normally place Pads…etc)
• Selected the Folder to Save it to (and,notice nothing until next step)
• Exit the Footprint Editor(though, I could have Double-Clicked the destination folder to make the next panel pop up)
• Panel pops up requesting to select destinatioin folder.

done

I’m on a Mac, perhaps other systems have different order of operation/clicking…

In my opinion, despite all the Good things about Kicad, it’s files management could be completely revised…

Copying and Renaming a Footprint
Watch the show…

At the moment you have created a new footprint with a footprint wizard, it only exists in RAM. If you then click on: Footprint Editor / File / Footprint Properties you can change the name of the footprint before you save it. Or you use Footprint Editor / File / Save As directly.
I just did this to verify it and it “just works”, it’s also the logical way, so I don’t really see the problem. There is one detail that can be misleading. some (or all?) of the footprint wizards put the name of the footprint on a fab layer, and that is just a text string, It is visible, but it does not change when you change the name of the footprint.

Edits like this are also easy to modify from an existing footprint. Try this:

  1. Modify a pad.
  2. Right click on it and select: Push pad properties to other pads.

A slightly different method is to:

  1. Modiffy a pad.
  2. Right lick and: “Copy pad properties to default”.
  3. Select a bunch of other pads (drag a selection box, [Ctrl + left click], etc.
  4. Right click and Paste pad properties to Selected.

KiCad-Nightly (soon to be V8.0.0) also has a properties manager in the footprint editor. So you can just select a bunch of pads, and then start editing their properties.

Hi Paul,
Regarding your comment:
…you have created a new footprint with a footprint wizard, it only exists in RAM. If you then click on: Footprint Editor / File / Footprint Properties you can change the name of the footprint before you save it.
This is certainly not the case, at least not with Microsoft Windows.
I recorded it here, and you can see at 1min17 sec that I try to click on the Footprint Editor window, and that’s not allowed by Windows, you can hear the “denied” windows sound on the recording:

Just to be clear, this discussion really is about the Footprint Wizard. I know how to copy/paste and save as footprints and edit them, but I’m trying to use the standard Footprint Wizard functionality, because it’s there, and sometimes that’s just the right option for a speedy footprint if you know the pad dimensions and spacings and so on.
I don’t get how the Footprint Wizard silently overwriting existing footprints with the same name could be expected functionality, hence the reason for the discussion, in case I’ve accidentally missed how to do that while using the Footprint Wizard, or if there’s a decent workaround (while still making use of the Footprint Wizard functionality).

Hello,
I have watched the video. Nowhere do you actually use the Footprint Wizard (which is key to the discussion)

You’re totally incorrect. The only thing you don’t see (because I previously clicked it) is my clicking the Footprints editor button in Kicad main panel. After clicking it, the panel opens to what I show in video. The next step is to click either of the Two icons on left - first one opens as shown. Second one opens to select a baseline of stock options for Pads…
After that, everything is as shown in video.

I saved myself the Extra Step of starting the Footprint editor because I figured you knew how to do that (sort of like Booting up Kicad, I didn’t tell you how to do that either… sorry!)

Screen Shot 2024-01-27 at 12.13.56

Screen Shot 2024-01-27 at 12.11.01

Please re-read the title, and the entire discussion.
I’m repeating myself for about the fifth time now.
I’m referring to the Footprint Wizard.
I am NOT referring to the Footprint Editor.
I was very polite about it when I asked you to clarify, and specifically asked (again) about the Footprint Wizard. I understand you are trying to help. I’m not sure how much clearer I can make it, I uploaded a video in my previous comment, and below is a screenshot.
footprint-wizard-image

That Wizard opens from Clicking the Second Icon I show… As I said, there are Two options… So, in response, ‘You’ are not paying attention/reading.

It leave to you from here…

I am slowly starting to see what you mean.

It is correct that you can’t switch back to the footprint editor without exiting the wizard first. Clicking Export to Footprint Editor as you did at 01:33 is the normal and correct way to transfer the footprint from the wizard to the editor. However, this should not overwrite an existing footprint. As far as I understand the function of the wizard, this should only put the created footprint in the editor, and nothing more.

I am experimenting a bit myself here. I just did:

  1. Create a new empty footprint library, add it to the project table.
  2. Start the footprint editor.
  3. Start the wizard, create a soic-10.
  4. Press the Export footprint to editor button.

After that, the empty library I just created had a soic-10 in it, and I was surprised about that. I am beginning to suspect that you discovered a bug here. This needs a bit more experimentation to discover how this overwriting bug is triggered…

Hi Paul,

I see… I thought I had missed something.
In that case, I’ll wait a day or two in case any easy-ish workaround comes to mind, otherwise I’ll raise a bug on GitLab.
Thanks Paul, and BlackCoffee.

1 Like

I can not really replicate the overwriting thing.
I now have a “shabaz” lib with 5 soic footprints:

Then I created another soic-24 but with wider pads and exported that one to the footprint editor. At 00:14 you can see that as soon as I go to another footprint, KiCad asks me whether I want to save the new just created soic-24 footprint.

If I save the newly created footprint with wide pads, then KiCad asks me whether it should overwrite the old footprint. If I cancel at that moment, I can still reload the old soic-24.

If I do the same again, and use “save as”, then it creates a new footprint as it should without overwriting the old one:

Just an FYI…

essentially the same as Save-As without the extra clicking…

Interesting! It’s very weird, I see different behavior.
I’m using version 7.0.5 (details pasted below).
I tried simplifying to just these steps:

  1. Create a blank, new Global Library
  2. Use the Footprint Wizard, and create any footprint, and click on the “export” button to close the Wizard
  3. Without saving, I click the X at the top-right of the Windows pane, to close the Footprint Editor. If I re-open the Footprint Editor, it contains the footprint! It seems to have saved it without me doing anything.
    Any debug to enable, or should I grab a video of these steps do you think?

Application: KiCad Footprint Editor x64 on x64

Version: 7.0.5, release build

Libraries:
wxWidgets 3.2.2
FreeType 2.12.1
HarfBuzz 6.0.0
FontConfig 2.14.1
libcurl/7.88.1-DEV Schannel zlib/1.2.13

Platform: Windows 11 (build 22621), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: May 27 2023 02:48:13
wxWidgets: 3.2.2 (wchar_t,wx containers)
Boost: 1.81.0
OCC: 7.6.3
Curl: 7.88.1-DEV
ngspice: 40
Compiler: Visual C++ 1936 without C++ ABI

Build settings:
KICAD_SPICE=ON

Video of the steps I took (created a blank new footprint library, used the Footprint Wizard, and then closed the Footprint Editor without saving; yet the footprint becomes saved.:

When I first created the “shabaz” library it was also empty (of course) and I saw very similar behavior. The first footprint I created after that with the footprint wizard was also saved into the file without any sort of confirmation. It could be the same bug i.e. if a footprint is saved when it should not be saved, then it is plausible it also overwrites an existing footprint if a footprint with that name already esists. But this is a guess. I also tried to repeat it but I could not replicate this behavior.


If you want to make a bug report, then first update to the newest stable release (Currently V7.0.10) In between those versions probably 300 to 500 small bugs have been fixed, and nobody is interested in grooming though that list. Adding such an old KiCad version to a bug report is likely to result in an instant reject by the bot.

Also, KiCad developers are a scarce resource. Developer hours are at least 3 orders of magnitude (4 or is more likely) more scarce then KiCad user hours. Anything we can do to further pin down how this bug gets triggered is a bonus. At the moment I’m confused why I saw it the first time, but not with the second library.

Hi Paul,

I understand; I don’t like creating bug reports without being fairly sure there is indeed an issue either, and as much information as possible (I was a software developer in the past).
I’ve just now tried the simplified test (new library, footprint wizard, and then close it and see that it got saved by itself) with the latest 7.0.10 version on Windows, and see the same issue.
Next I tried to create a second footprint, and noticed that it still over-wrote the first footprint.
I’m 75% sure this issue existed in earlier dot-releases of V7 too. For me it’s consistent, I can’t seem to get to a situation where it prompts me to save.
I’ll record a video with the 7.0.10 release and get the bug report created.
EDIT: Done, bug report created here: Footprint "Wizard" workflow overwrites earlier footprints, and does not request to save the footprint (#16789) · Issues · KiCad / KiCad Source Code / kicad · GitLab

2 Likes