Removing value and reference from PCB


#1

How do I remove the reference and/or value silkscreen from a module in Pcbnew?

I’m assuming there’s a way, as most PCBs don’t have both these things for each and every component.

I can individually set the reference and value to be blank, but this seems like a drawn-out hack rather than a solution.

I’m migrating from Eagle to KiCad, so I’m having to re-learn a lot of stuff, this is one of them.

Thanks in advance.


#2

Oh, I have tried searching for this. Either I’m not quite getting my search terms right or it’s so obvious that no-one’s felt the need to write it down before.


#3

Hover over the reference or value and hit ‘e’, there you can toggle visibility. I’m not sure if the website builds have it, but if you have a recent build there is a ‘Cmts.User’ layer, instead of hiding a reference / value I prefer to move them there, so they still show up on a printout (which I like to keep at hand while assembling), but not in the CAM files.


#4

If you just want to hide one of them while working on the board layout, switch the visibility of the values or the references from the layer manager (the pane with layer names on the right, in its second tab.
When plotting to gerbers later, you can choose to use them or not too.


#5

Ah, the visibility in the “Render” tab was the step I was missing. Thanks!


#6

Stefan,
I like that idea, how to you move it to then ‘CMT.User’ layer?


#7

Hitting ‘e’ over the reference and using the layer dropdown. Or am I missing something in your question?

You can do this in the footprints too, if you want to have this by default.


#8

That is it thanks my friend.


#9

In the layer manager toolbar, under the Render tab, there are “Values” and “References” you can toggle them on and off.


#10

Fantastic, thanks. Was going crazy trying to figure out why they didn’t disappear even when I turned the F.Fab layer off.


#11

I have disable the reference on a single component through the hover approach. How do you I re-enable it?


#12

Option 1: in the render tap enable invisible text and use the hover technique again.
Option 2: open the footprint properties (press e on top of the footprint) and edit the text field properties. (This only works for the main reference and value fields, not for secondary fields used in the newer footprints of the library.)

Disclaimer: This screenshot and information comes from a development version. Small details might differ in the stable release.


#13

Great!! Thanks for the tip and quick reply!!