Removing Keepout area

Still editing someone else’s board. She has drawn keepout areas where we don’t want them. The first one I tried to delete worked as expected - I selected it and deleted it without problems. The other 3 I cannot select or delete. Can’t edit. When drawing a keepout area, you can select what to keep out - traces, footprints, or zones. No idea how she created them, but I need to fill the zone where the keepout is, and it won’t fill.

TIA

bdh

There are two different ways to create an keepout area.
One way is as a separate entity: Pcbnew / Place / Keepout area (also in the toolbar on the right). Because this is a separate entity, it can be selected and deleted.

The other way is to first create a Zone, then select it and from the Right Mouse Button popup menu select: Zones / Add a Zone Cutout. Such a cutout is a part of the zone itself. To delete such an area inside a zone you have to be a bit careful. KiCad likes to select the Zone itself instead of the cutout in the zone. What works for me is:

  1. Select the Zone itself.
  2. Drag one of the corners of the cutout in the Zone (This makes KiCad focus on the cutout. (Yes, actually move a corner)
  3. Right Mouse Button, and from the popup menu: Remove Corner.
  4. Repeat removing corners until the whole cutout is gone.
1 Like

I have no idea how she created them, but the keepouts are in the corners of an irregularly shaped board. We don’t want components or traces on the surface layers, but this is an internal ground plane. I am guessing, but the first one was probably drawn by hand, and then copied as a block to the other corners. Thus, I was able to select and delete the first one. But why not the others? I thought perhaps if I remove the ground plane and then select the keepout as a block by drawing the bounding box around it, perhaps I can delete it. It worked! Learned something new.

Thanks

Bruce

Selecting things can be a bit troublesome on a crowded PCB.
Tip: Dragging a selection box from left to right only selects objects that are fully enclosed, while dragging from right to left also selects items crossing the boundaries.

1 Like

Interesting. My hope is that the method of drawing the selection box is eventually changed to the same method as drawing a polygon. What you need to select is not always selectable with a rectangle.

While holding [Shift] you can drag another box to add more to a selection, and while holding [Shift] you can also remove single items from a selection.

Drawing a “fence” around an area to select things may come at some time, but I’m not even sure if it is that useful in KiCad. The problem is there are multiple overlapping things. Footprints, texts, Tracks, via’s, graphics. KiCad-nightly V5.99 has expanded on that by integrating an easy accessible filter (in the bottom right corner) to select which items can be selected or should be ignored.

v5.1.9 also has a filter, but AFAIK the way to access it is through the right-click context sensitive menu. (So, Yeah. Kinda hidden.)

In V5.1.x there is indeed also an selection filter. First select, then: [RMB] / Select / Filter Selection.
image
It does not work continuously though. If you change it’s settings, then in the next selection, it defaults again to selecting everything. (Although it does remember which boxes were checked).

The selection filters in the lower right corner of V5.99 simply always ignore items (so they can’t even get selected) for which the check boxes are checked.

1 Like