Remove solder mask on pcb antenna


I designed PCB trance antenna for Bluetooth application and I am trying to convert it to gerber file for the measurement. Here is my question to ask. I would like to know how to remove the solder mask on PCB antenna pad.I tried to uncheck F.mask as technical layer. But, it keeps showing on 3D viewer. Please help me to solve this problem.


that footprint might be made up of a graphical polygon on the copper layer and a pad overlapping it. The pad will be a default smd pad which has paste and mask enabled. Remove these two from the pad definition.

Hi Rene_Poschl,

You mean unchecking both paste and mask from the pad definition(technical layer)? After following your suggestion, I got no gray on my antenna.

Yes. Gray is actually paste in the 3D view. The physical mask substance is green in the 3D view but in the layout editor it’s an inverted layer - the green mask is removed from where there is graphics in the layout layer. Normal pads have Mask and Paste checked so that you have bare copper and paste in the physical board. If you want bare copper without paste you have to uncheck Paste in pad properties. If you want copper covered with mask substance (like the rest of you antenna or normal tracks) you have to uncheck both Paste and Mask.


@bbrotherone What eelik says is true. But the fun part is you can extend this to get an odd behaviour. AFIAK there is no check to make sure that solder paste is only on bare copper. So you could disable the mask in the pad definition and leave the paste.

@all I wonder if this is ever desired as a use case, or if paste w/o mask should be a DRC check. (It might be, I haven’t verified that. All I verified is the FP editor allows one to do this.)


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.