Remove redundant track doesn't work

Hello,
I’m using Kicad PCB and I never see “Remove redundant track” working when interactive routing, despite it is activated.
Is this an issue, a misuse ?
Thanks a lot in advance.

Application: KiCad PCB Editor x86_64 on x86_64

Version: 7.0.10-7.0.10~ubuntu20.04.1, release build

Libraries:
wxWidgets 3.2.1
FreeType 2.10.1
HarfBuzz 6.0.0
FontConfig 2.13.1
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Ubuntu 20.04.6 LTS, 64 bit, Little endian, wxGTK, xubuntu, x11

Build Info:
Date: Dec 31 2023 13:35:27
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.88.1
ngspice: 38
Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:
KICAD_SPICE=ON

The function definitely does work:

… but it does not work always / reliable. I do not regard it as a reliable function, but as a “little extra” that makes routing sometimes a little bit easier. I never paid much attention to this. A quick cleanup is to hover over (no clicking needed) the redundant track, press u to select it and then [Del].

After a bit of testing. It appears to work when the new route goes directly to a pad (as in the first example) or to the endpoint of the last track segment. This function is also blocked if the section to remove has any stubs.

1 Like