Remap symbol do not fully compatible with 4.0.7


#1

I using customize symbol, and the previous KiCad version allow you to set the symbol name without lib name, for example you can either say lib1:opamp, or just opamp for “Chip Name”. KiCad 4 will find the match for it with giving set of libraries in project. Now, when I open the schematic in KiCad 5, all my symbol are recuse, but “Unlink” with the original symbols libraries. With this, it force me cannot migrate to KiCad 5. Please allow remap function to search for symbol name in available library before it create it’s own lib from cache file.


#2

remap will search in existing libs. But you need to add your libs to the sym-lib-table for this to work. (If you used symbols from the official lib be aware that nearly all symbols changed going from version 4 to version 5. This might be the reason why kicad does not find your symbols any more.)

Oh and if you had version 4.0.x running before you might be affected by this: (click the link or the triangle to read the full post)


#3

Thank for a guidance. However, it is one of the tries that I had done. Below are two significant tries I did:

  1. After seting the project library link, so that KiCad5 save it into sym-lib-table under project folder. Then every time I try active remap the sym-lib-table file got removed (which seem to discard all my setting for local library for the project). Giving this behavior, I would think follow improvement may help:

    • The *.pro file should not be discard by KiCad5 from the transition process, because it was contain information of the library that project were used. It should instead keep that setting in .pro file, and use it to convert into the sym-lib-table if the sym-lib-table did not exist. This ways some people still using KiCad 4 still at least loading the project correctly.
    • I realize that, I have to restart the KiCad5, and restore the .pro file to it’s original before open my project with KiCad5. And it loaded fine (remap not event prompted). So this kind of acceptable for me, but it is very picky process and non-intuitive way of doing thing.
  2. I try setting global sym-lib-table instead. In other to have remap “work”, I had to close and restart KiCad5 then active the remap. However, the remap result is what I not wanted as stated at being of this forum. That is, the remap make a copy of gobal sym-lib-table but added number “1” after all the library names. Then map all the symbol to those instead of using the global setting!!!. I think this behavior is not sound. Also, this remap only work on the first time that it use .pro file from KiCad4, but then KiCad5 modify the .pro file to discard all the lib setting that I mentioned in try#1, which cause the remap not able to map regardless what method I try! Again this behavior is not sound to me.

    • I found that KiCad5 is more picky on the Library Symbol name compare to KiCad 4 as I mentioned at begin of this forum. That is, KiCad5 required full path lib1:OpAmp where KiCad4 work with both lib1:OpAmp, or just OpAmp in the Library Symbol field when you try to click on Validate button. In my option, it is a quite big of downgrade.

#4

It is a big upgrade. In version 4 kicad picks the first OpAmp symbol found in your libraries, there can be several OpAmp symbols in different libraries. So it will pcik up lib1.OpAmp even if you want lib2.OpAmp symbol.
In version 5 kicad picks the very OpAmp you want because you specified the lib OpAmp belongs to.


#5

To pedro,
I totally understand that reason. However, I think allowing two style as KiCad4 did, allow you to either do exact specify the library name, or not. This is very convenient if your project library symbol keep moving around from one library to other library for the organize reason. Also, if there is a conflict, KiCad may detected it and warning user, and may just pick the first one it found base on the library setting order. User will have multiple way to work on that or leave it for KiCad to decide.


#6

My suggestion is to keep kicad 4 running for old projects and use kicad 5 for new ones.

I also had some instances when kicad added a 1 to the lib name. Not sure why it does this. Maybe read the documentation written by wayne as he was the one developing this.

There is a neat tool to fix this easily however. It is found under tools -> edit symbol libraries references.


#7

Ah ha, thank Rene_Poschl for pointing me to a new tool I have not noted. It seem the be an improvement feature – love it. I hope it improve in the future for direct modify the text in addition to selected from the library. (Just a though). It is good for small size, not large size project may not be easy to make a transition. I know I still have to stay with KiCad4 for a while, but I’m just too excited to try out the new KiCad5.


#8

After work around with remap - using the Edit Symbol Libraries tool (Map Origin), and try to keep .pro file unmodified. KiCad5 and KiCad4 pretty much can be work in parallel for eeschema. Thank you beautiful work. I can use KiCad5 without make others to move into KiCad5.


#9

To be honest you will run into trouble if you use kicad 5 while others still use kicad 4. kicad is not backwards compatible. Especially on the schematic side (And it really has nothing to do with the project file. As you already noticed, kicad 5 now stores the lib name as well not only the symbol name. Kicad 4 does not know how to deal with that. It might sometimes seem like it could work but i bet if the person uses the save button all hell breaks lose.)

Just yesterday somebody asked about opening kicad 5 projects in kicad 4. See my answer for details about the incompatibilities: How to open kicad 5.0 files in kicad 4.0.7?


#10

So my question is, is there a plant for backward compatible in any KiCad moving up version? Or eventually people have to split the KiCad into multi-universe?


#11

No. But there will always be a path to convert old projects over to the new version.

That path will however not be perfect all the time.
Right now it will take a bit of time till we (the users) fully understand how to get the remapping process to always work perfectly. (Until that point in time we can not really create good foolproof tutorials)
For example my personal libs never get a 1 added. But the power lib of the official lib gets it. I have no clue why. (So i can not really help you out with that other than suggesting to either fully convert or keep a dual setup in place till such time where you can fully convert)


#12

I do not have a problem with convert with new or on going project into KiCad5. But my trouble is that, most of the project create on KiCad4 (or older version) are a freezed design, just as same as KiCad4 now freeze. So that mean, we will switching KiCad versions constantly just for read-only operations. Most people don’t have a intention to migrate freeze projects. For example, I will not re-generate Gerber drawing from KiCad5 at all but rather use exact KiCad version at the time. But for just open it up for read-only operations it would be nice to not constantly switch KiCad versions.

To me generate a spice netlist for run simulation also a read-only operation, but KiCad5 drop the spice directive “+pspice” or “-pspisce” is also a issue for freezed design.


#13

If your designs are read-only, you might mark them read-only in the filesystem to avoid accidentally changing the files. Then, open in KiCad v5, skip the re-map and use the system as read-only.

Alternatively, you can simply make a copy of your frozen designs before opening them in KiCad v5. This also ensures that nothing changes in your originals.


#14

I’m guessing I’m asking for a more friendly remap process than what it is now to not having user to manually create a sym-lib-table file manually. May be this https://bugs.launchpad.net/kicad/+bug/1747599 issue will do.