Reinstall KiCad withot any loss

Hi all,
I think I got an issue with KiCad and wish to reinstall the package.
Will I loose my work?
If I just save the project directory and then but them back will it be OK.
Francesco C

You should not lose work as long as you did not place personal data in KiCads installation directory.

This includes the libraries shipped with KiCad so if you modified the library files then these changes will be lost (which is why the library is normally read only without admin rights such that it is unlikely that users fall into this by accident).

KiCad does not even reset your personal settings directory on reinstallation. So a reinstall might not even fix the issue you see. If you could give details as to why you think a reinstallation is necessary then we might be able to possibly give you guidance as to how to fix the issue you face.

Hi Rene,
thank you for your replay.
I have not been able to get 3D on the 3D viewer.
It was OK when I started the project, Now an entire range of 3D model shows only the footprint.
The problem rebates to the connector library. All the other 3D models are there.
I checked the path it is OK.
In-fact,this happened when when I started a new project.
So opened the old project and also there the 3D model are gone, but only for the said library.

Do you think I should reinstall?
Francesco C

Do you have an example footprint name? Is it one from the official library? Are you sure that particular footprint really has a 3d model (only a small number of footprints have a model file, the rest is just prepared for one).

Hi Rene,
this is one of the 3D model missing.

It is OK in the previous project.

There does not seem to be a 3d model for this footprint in the official library (there is no folder called TerminalBlock_RND so there definetly is no model for this part)

Is it possible you had a personal 3d model or is it possible you had a different footprint in the old project? For example terminal blocks by phoenix contact have 3d models and they look quite similar to some of the RND ones.

Hi Rene,
see this screenshot

I am confused what information you want to tell me here. The link i posted above will lead you directly to the 3d models that are distributed with kicad. You can search this repo yourself but it looks like there is no model for the specific footprint you show. (There simply is neither a step nor wrl file in the repository, in fact there is not even a folder for the RND terminal blocks.)

I can not even find models for these in the old version 4 repo so i would guess there never were official models for them.

So are you sure you ever saw a 3d model for this exact footprint?

Again there are many footprints distributed with kicad that do not have 3d model files. However, ALL footprints have a model path set such that a model can be added without the need to touch the footprint. Yes this might be confusing, but some decisions are made to simplify the work needed for maintaining the library (the slight chance of user confusion is worth the benefit of man-hours saved on the maintenance side).

Hi Rene,
I found the issue.
I checked the previous design.
I found there was a secondary choice in the description of 3D Models of the footprint.
Probably I was searching to find the one that worked.
So I was misled.
The second line is the one that worked.
Thank you for pointing me in the wright direction.
So now it is working if I select the Phoenix model.
Thanks again.


Just be aware that you can not use the phoenix model for anything other than eye candy (as it will most likely be different than the RND version).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.