Reference text and footprint name

Good Morning All!

How do you remove reference text that is in the silkscreen layer? I had not had my coffee yet and clicked on a wrong Footprint and it got inserted. I can delete almost all of the Footprint although the REF** and Footprint name can not be deleted. I tried moving it to a ‘user’ layer, but still could not delete.

I did search for just this, all that shows up is marking it ‘hidden’.

Yes, I suppose that marking it hidden works, but I like keeping stuff clean and tidy.

Oh, KiCad 6.something on Fedora 36


The point of the reference text is not just to keep it visible somewhere, but also to identify the component for all parties involved and tie it to a schematic symbol. Therefore it would be wrong to remove it completely. It don’t think “clean and tidy” is a good enough reason to make that possible.

You can turn off the “hidden text” in appearance → objects (window on the right side)

eelik: Thanks for the reply. The component ( footprint ) does not need to be identified as it was deleted from the schematic. Just trying to clean stuff up.


Do you mean you first had a symbol + footprint combination in the design but removed the symbol and wanted to still keep the footprint in the layout? I would argue that keeping the Reference placeholder is still better than removing it completely. It shows at once that the footprint isn’t tied to a symbol, and you can hide it from the PCB.

eelik: No, footprint got put in by mistake; wrong one. I know I can hide it although it makes more sense to me to remove all traces so-to-speak.


If I understand correctly what you did: you tried to remove footprint from a layout (board) by opening the footprint and editing it to non-existence. Instead, you should simply delete the footprint from the layout.

1 Like

Not quite. Selecting via cursor window and then hitting delete removes most of the footprint. REF** and Footprint name are still there and I can not remove. Where did I go sideways?


Can you zip the project and attach it here?

Where did you hit delete? Was that in the Footprint Editor, or in the PCB editor?

I can, although I wonder if that is really needed as I started with a footprint as I was size checking because I do not have much real estate to work with so I thought I would try and see what would and would not fit. Footprint is the only thing there. Well, REF** and name. Sure, can delete the whole project; but what happens in the future when I insert something wrong on something that is further along that this is? I mean sh.t happens especially with me.


paulvdh In the footprint editor.


Ahh, OK. If you added a footprint to a layout and then want to delete it, you should not open the footprint in the Footprint Editor to delete it. You should select the footprint in the layout so that it is highlighted and then simply delete it (press Del or use the Right Mouse Button menu a.k.a. context menu → Delete).

1 Like

Thanks will give that a try and let ya know!

There’s one catch. When you have already edited the footprint so that it has nothing but the reference and the value, it’s difficult to select the footprint. You have to click the anchor of the footprint on the board. It’s the small plus mark in the anchor (internal origin point) of the footprint. Then the whole footprint is selected.

Or: PCB Editor / Edit / Find then search for your reference text to select it, close the find window and depress [Del].

Or View → Search Panel and possibly type in the Reference designator, then click that line. (EDIT: doesn’t work in KiCad v6.)

We’ll see who’s got the final word in the “find all possible ways to do the same thing” competition. :grin: Next, opening the file with text editor…

All: Sorry for the delay, had to go back out into the Train Cave as that machine is not VNC-able…yet. Somebody said food, so I came in the house and asked my question. That worked, we are all good now. Sorry to take up your time. Sometimes ima sooo St00pid!


Have you tried Update pcb from schematic?
The symbol was deleted from the schematic anyway.

:1st_place_medal: to pedro.

That should work if you select the option for removing footprints not having a symbol.