Reduce "copper filling" on footprints GND pad

I’m finalizing my PCB. I have 2 somehow fine pitch IC that will be hand soldered. Checking the PCB, I see that the GND copper plane filling makes the GND pads of the footprint “wider” (see attached pictures). They appear to be wider below the chip. So if a solder bridge appear there, it will be difficult to spot.

Is there a way to keep the GND pads of the IC with the same width as the other pads, to limit the risks of solder bridges ?

(there are places where the wider zone is longer)

Best regards,


You can overwrite the thermal spoke parameters set in the zone within the pad settings (so if you generally want the larger spokes overwrite it with the smaller settings where required).

It is strange that KiCad tries to make the horizontal spokes even though it can not connect them. Looks like a bug to me. What version are you using?

I use 5.0.2

Following your advice, but having difficulties to understand thermal pads parameters (what means 0, ordres of magnitude about what is ggo to use,…), I modified the pad’s “connection to copper zones” to “None” , and I added tracks to cennect to the copper zone.



update to 5.1.5, it is fully compatible with your version. The user interface has however changed quite a bit so be prepared to relearn a few things

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.