Reduce clearance of groundplane

whaw, it wasn’t :slight_smile:
Each forum has it’s habits

Try this:

Edit the properties of your copper zone and set “Pad connections” to “Solid”

(Also press b again after the dialog is closed (just to be sure))

No luck, nothing changed with the following settings

and when clicking on the settings all went back to the default

You have written that also in your first post. I think here is the problem source. But I don’t know what can be the reason for.

I needed to do something but had the same/similar problem. I solved it by doing some homework/testing… The solution is not apparent but, it’s right in front of your eyes…

This (the settings) may suggest a starting point…

Just did a reinstall of the software V5.1.12: no cure however
Is there any else on the forum facing the same problem?

… the Hint is understanding the effects of changing Clearence, Min Width, Thermal Cleraance and Spoke values - once understood, you’ll come the solution…

EDIT _Added:
Once happy with all else on the PCB, make the changes as needed but DON’T Re-fill it!! That puts an additional Gap around it

Here are some examples of tweak a affects…

I have 5.1.10 for Windows. Few days ago I was looking if there is 5.1.11 but it wasn’t.
Now I see 5.1.12 is there. May be with .12 something wrong happened.

V5.1.11 has been bumped to V5.1.12 because version numbers are for free and it can avoid some confusion.

V5.1.12 is now also availabe on my linux box.

I have just installed 5.1.12 (Windows), opened one of my projects went into edition of GND zone and changed Clearance (from 0.25mm to 0.5mm). When I clicked [OK] button my zone was rebuild correctly.
While finishing that sentence I suddenly noticed that I have [OK] and [Cancel] buttons reversed then you (OK is on the left). And behavior you describe looks like when pressing [Cancel].
Is it possible that your buttons just get wrong texts on them?
Try accepting your changes by clicking [Cancel] :slight_smile:

The order of the [OK] and [ Cancel ] buttons are either directly decided by your OS, or KiCad deliberately changes the order to conform with “good practice” guidelines for the different operating systems.

So that the order of those buttons are different is nothing special, but there is nothing wrong with double checking if there is some kind of bug in this area.

The reason for aways returning to the default values was my mistake: one have to click on the edge of the zone, not inside the zone. But for some reason I tumbled into another problem. When pressing B a message pops up for a fraction of a second telling “removing insulated(?)/isolated(?) copper islands” and another message about polygons…
What I also noticed when B is pressed the ratsnest disappear but nothing is filled.
Any idea what is happening here???

As you gave Copper Zone Properties screenshot I assumed you got it by clicking on the zone edge. How clicking inside the zone you got that edit window? I can’t figure out how to do that.

That means that KiCad filled the zone but it got several separated parts (islands). Some of them had not connection to any pad with the net specified for zone so as not being connected with anything they were removed (unconnected part of copper at PCB is not a good thing I think).

May be you have switched off showing the filled areas in zones so they are done (so ratsnest changed) but not showed.

Hi Piotr,

Thanks for the reply.
I wrongly selected the ‘add filled zone’ button to change the properties of that zone…

I removed the current project and reloaded the archive I made in the beginning of this thread.
With this (previously) working project the filling is not happening too because these messages are still there.
It looks to me the software is messed up.
So I removed the Kicad folders and did a new installation, but the error persists.
Sideway question: are there files belonging to Kicad that are NOT in the Kicad folders which mess up functions like B?

In Windows KiCad writes its configuration in C:\Users\{your name}\AppData\Roaming\kicad. Don’t know how in other systems. If you want really clear KiCad installation you should uninstall it and delete that directory.

I don’t think so, but…
You probably can assign your own hotkeys to functions (I never tried it) so B could run different action, but … I don’t expected it happened in your case.


Went back to V5.10, however without any success.
When pressing B to redraw the zone, the messages keep popping up for a fraction of a second.
Not sure, but I guess something outside Kicad is corrupted reusting in this behaviour.
Completely stuck now.
I’ll try to raise an issue.
All thanks for looking into!

I don’t know if that can be a source of your problems but…
Windows KiCad PCB can work in 3 ways - see Preferences - F9/F11/F12.
F9 - Legacy Toolset works old way, I had to use it rarely in KiCad 4.0.7 as I could’t do all in F11.
F11 - Modern Toolset (Accelerated) - I use it. If something with acceleration (I understand hardware in graphic card) don’t work correct than may be it can generate your problems, but don’t know.
F12 - Modern Toolset (Fallback) - without acceleration - I understand it should work at all PCs.

Problem solved: the “do not show filled areas in filled zones” was activated!
Clicking on it’s counterpart solved the problem.

I wanted to copy only that but forum don’t allows to post “empty” posts so I added that sentence.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.