Reading netlist but nothing happened

Hi all !

I’m a french engineering student using kicad for his school robotic association.

One of my fellow comrade designed a printed board for one of our robot. I need today to adjust it to match new goals.

So I change the schematic, the CvPcb associations and create the netlist. I also delete _pcb & _pcb-bak files (for make the design the cleanest possible I want to start pcb layout from scratch).

Then I start the Pcbnew tool. But after pressing netlist/read current netlist & close nothing happended ! :confused: (usually this put modules on the worksheet…)

I can upload the files (first unmodified and new one) if you need to.

Any help will be very much appreciated ! :slight_smile:

ps: I’m using build (2013-jul-07)-stable on 64 Bits GNU/Linux

Hi Charles,

i think be careful with the order you do the steps:

  • make your changes in your schematic.
  • if you add new symbols - Annotate
  • export NetList
  • run CvPcb to associate footprints to symbols (hit the save button if you are done!!)
  • open Pcbnew
  • select and read netlist file

what do you get in the Message box?
there should be something like

Reading Netlist “C:_Local_DATA_projects\Test_PCB\”
Using component/footprint link file “C:_Local_DATA_projects\Test_PCB\Test_PCB.cmp”
Component [SW1]: footprint ‘x_Switch:smd_momentary_switch’ not found

(but without the ‘not found’ :wink: )

sunny greetings

Hi stefan,

Sorry for my delay. Thank you for your answer !

We have changed the design of our board, creating a totally new one. That time kicad work as well as usual.

I have not yet fixed the problem that I exposed to you. I will try to do so when I will have more time (for curiosity ^^).


Hi, s_light I have that problem. I have installed Kicad in my Mac and in Ubuntu OS and have exactly the situation yo describe in both OS. Works fine in Eeschema, but when PCBNew, reads the netlist, can’t find the footprints. What have to do to correct te problem? There are some configuración adjustments? Please help me!!!

Which situation? The ‘footprint not found’ message?
If yes - this means your fp-lib-table is not-working/out-of-date… please use the search function of this forum with that term along with ‘mac’ or ‘osx’ or ‘ubuntu’ or ‘linux’… there are 2 pretty long thread with how to solve this step-by-step

1 Like

In the dialog for Netlist Import there is a check-box labeled “Dry Run. Only show messages.” If you have this checked, PCBNew will NOT import the components to your board, but will still tell you all the information about components that would be imported if you allowed the program to do so. This is actually a very handy feature that permits you to preview the changes before they happen.

Also, all of the imported components will be stacked on top of each other in a pile, perhaps at some obscure location away from the area shown on your display. Do a search for “KiCAD glob” to get information about dealing with this.


Let me show some screens:

You can see, I have no problem with Eeschema, my real trouble is when I try to build the PCB, the app can´t find the footprints when PCBnew reads the netlist. Hope you can help me please.

I know the following points sound very basic, but . . . .

Did you remember to “Save Edits” before you quit CVPCB?

Then, did you generate the netlist AFTER you assigned footprints?

Finally, did you tell PCBNew to read the correct netlist file, not some previous version?

The netlist file will have an extension of “*.net” and should be in the project folder. Open it with a text editor and see if every component has a “footprint” attribute defined. See atch.


In PCBNEW click the “netlist” button, next under the “Exchange Footprint” section click “change” then click “ok”.
Is that what you are looking for?

1 Like

I think the problem is with the Mac and Ubuntu Versions, so I´ll wait to the next version to see if the problem is corrected. I have checked every configuration and all seems ok, I have reinstalled several times the Kicad in both versions and always do the same. Only the first time I installed it worked fine for a while, then Kicad crashed

As said above, generate the netlist file from Eeschema AFTER save the footprint association in CvPcb.

1 Like

In the first time that install Kicad worked fine, but something happens and blocked it, so I uninstall and reinstall the app and since then I have that problems. I figured out it was only in my Mac, so I rescued my Toshiba laptop with Linux Mint OS, the same thing, worked fine, but something happens and blocked it, did the same, uninstall and reinstall Kicad, and I´m here, All my works stopped and doing easy PCB´s with Eagle for a while… If somebody knows how to resolve, please help me, or I´ll wait until next Kicad Version. I have checked the directories and the paths and everything looks ok

What happens when you click on any component (try different footprint repos) on the right hand pane in cvpcb (marked in red) and then hit the little inspection button to the top left of that cvpcb window?
Can you see the footprint then?

And while you’re at it… post the net list file please.
The one that is behind the path in this screenshot would be needed (marked green):

The red marked lines in that screenshot tell us that there is no information coming through from cvpcb…
That is what @dchisholm tried to get information on, but you didn’t react on it.

Also, just a hunch, but you might want to avoid [SPACE] in folder names and file names… I can see that for the project you got there: ‘Dimmer Electronico’.
Convert those to dash ‘-’ or underscore ‘_’.
Will make your life much easier down the road as it’s 90% of the problems with multi-OS software IMHO in regards to configuration of paths/files.

I’m an ElementaryOs user (Ubuntu in fact) and I don’t have any problems loading and reloading footprints in the netlist file if I generate it after the footprint association (not before as described in the manual)
Please confirm this in your computer

1 Like

How do you load and reload the footprints? That could be my problem. Explain me please!

I reinstalled Kicad and created a simple oscillator circuit with the 555, Eeschema fine I finished the diagrama, annotate schematic, make electrical rules checker, generate Netlist and make the footprints association CvPcb, checked the netlist with text editor y everything is ok, apparently. The problem stars when open PCBNew, open the footprint libraries wizard and update the footprints, after download all footprints from github, Kicad freezes and remain blocked until I forces the end of it. When I restart and try to continue with PCBNew there appears all the errors before described.

Here are some screenshots:



Trying to read Netlist:

Netlist file readed:

Netlist file:
Oscilador (5.7 KB)

You need to run cvpcb then generate the netlist. Your netlist file you posted does not have any footprints, which is why pcbnew says it can’t find them.

1 Like


The order is wrong:


You got it!!! Thanks a lot for your help. I just follow your order and now I´m on the way!!! Thanks… Thanks… Thanks